summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2015-06-20 09:14:53 -0700
committerEric Anderson2015-06-20 09:14:53 -0700
commit6c2eeb4aef5d733aaafeae43d284515cc22c729a (patch)
treed6a56150ea9a4b28c5c61da83d345cc0eaab6d1b
downloadaur-6c2eeb4aef5d733aaafeae43d284515cc22c729a.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rw-r--r--quarry.install16
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21369148b661
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = quarry
+ pkgdesc = A multi-purpose GUI for Go, Amazons, and Othello
+ pkgver = 0.3.0.1
+ pkgrel = 1
+ url = https://gitorious.org/quarry
+ install = quarry.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = xmlto
+ depends = librsvg
+ depends = desktop-file-utils
+ depends = gtk2
+ optdepends = gnugo: play Go against the computer
+ optdepends = grhino: play Othello against the computer
+ source = quarry-0.3.0.1.tar.gz::https://gitorious.org/quarry/quarry/archive/a6003cd78d9d3045aa65f11db3fdd05a0bff31fb.tar.gz
+ md5sums = 11039e0c0fef8ccfdc6aeadfb6ae73bd
+
+pkgname = quarry
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eaab960e939
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Eric Anderson <ejona86 at gmail dot com>
+# Contributor: delmonico <delmonico at gmx dot net>
+
+pkgname=quarry
+pkgver=0.3.0.1
+pkgrel=1
+pkgdesc="A multi-purpose GUI for Go, Amazons, and Othello"
+arch=('i686' 'x86_64')
+url='https://gitorious.org/quarry'
+license=('GPL')
+depends=('librsvg' 'desktop-file-utils' 'gtk2')
+optdepends=('gnugo: play Go against the computer'
+ 'grhino: play Othello against the computer')
+makedepends=('xmlto')
+install='quarry.install'
+source=("$pkgname-$pkgver.tar.gz::https://gitorious.org/$pkgname/quarry/archive/a6003cd78d9d3045aa65f11db3fdd05a0bff31fb.tar.gz")
+md5sums=('11039e0c0fef8ccfdc6aeadfb6ae73bd')
+
+build() {
+ cd $pkgname-quarry/
+ ./configure --prefix=/usr
+ make
+ make html
+}
+
+package() {
+ cd $pkgname-quarry/
+ make DESTDIR="$pkgdir" install
+}
diff --git a/quarry.install b/quarry.install
new file mode 100644
index 000000000000..7b00834c318d
--- /dev/null
+++ b/quarry.install
@@ -0,0 +1,16 @@
+post_install() {
+ post_remove $1
+
+ echo 'To play against computers, you must manually add GTP Engines in preferences:'
+ echo '- For GNU Go, use "gnugo --mode gtp --quiet" as the command'
+ echo '- For GRhino, use "gtp-rhino" as the command'
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+ update-mime-database /usr/share/mime
+}