summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Boughton2020-06-12 14:06:08 +0100
committerNick Boughton2020-06-12 14:06:08 +0100
commit3277f62e34ef1379547f0b5c7368eab7dea42db3 (patch)
tree9bc73d8ce0ef0b9c6ea54e231e7dea98def3e52c
parent39af479049c8a5fa3b838dc74a09029e021a40ff (diff)
downloadaur-3277f62e34ef1379547f0b5c7368eab7dea42db3.tar.gz
implemented node packaging guidelines
-rw-r--r--PKGBUILD2
1 files changed, 0 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2d9d3a527b89..dc848d83924e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,8 +39,6 @@ package() {
# print first line (the '{' symbol) and lines from the first non-underscored key to the end
# (npm internal keys are underscored but we don't need these keys)
sed -i -n '1p;/ "[^_].*": {$/,$p' "$pkgdir"/usr/lib/node_modules/"$_npmid"/package.json
-# sed -i "s|$pkgdir||" "$pkgdir"/usr/lib/node_modules/"$_npmid"/node_modules/sshpk/package.json
-# sed -i "s|$pkgdir||" "$pkgdir"/usr/lib/node_modules/"$_npmid"/node_modules/he/package.json
# Add license
install -Dm644 "$pkgdir/usr/lib/node_modules/$_npmid/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"