summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Boughton2019-07-08 10:22:39 +0100
committerNick Boughton2019-07-08 10:22:39 +0100
commitca0090fadf2c3608dced3c1c5f5690b94be963ac (patch)
tree4240ec836cc3effcae9f2afdf5272fd542f4ded0
downloadaur-ca0090fadf2c3608dced3c1c5f5690b94be963ac.tar.gz
initial package version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13d3759709bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = quasar-cli
+ pkgdesc = CLI management tool for development with the Quasar framework
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://quasar.dev
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = npm>=5.0.0
+ depends = nodejs>=8.9.0
+ optdepends = npm: JS package management support
+ options = !strip
+
+pkgname = quasar-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c834dfa9936e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nick Boughton (nicholboughton@gmail.com)
+
+pkgname=quasar-cli
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='CLI management tool for development with the Quasar framework'
+arch=(i686 x86_64)
+url=https://quasar.dev
+license=(MIT)
+depends=('nodejs>=8.9.0')
+makedepends=('npm>=5.0.0')
+optdepends=('npm: JS package management support')
+conflicts=()
+options=(!strip)
+
+package() {
+ npm install -g --prefix="$pkgdir"/usr @quasar/cli@$pkgver
+ find "$pkgdir"/usr -type d -exec chmod 755 {} +
+}