summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleg Shparber2015-06-04 01:43:46 -0700
committerOleg Shparber2015-06-04 01:43:46 -0700
commitdf8cdabbad89a8ae6652e1bcedf0c5324eefebae (patch)
treee7c8bb7eb2afd302b660100ae40825cf69c231b2
parentcf0f1508c90173265546c6f2ca0ab8d72c3afa9d (diff)
downloadaur-df8cdabbad89a8ae6652e1bcedf0c5324eefebae.tar.gz
quassel-light: Add patch to fix CMake HAVE_SSL check
More info: http://www.cmake.org/Bug/view.php?id=15570
-rw-r--r--PKGBUILD5
-rw-r--r--fix_ssl_check.patch11
2 files changed, 16 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8322e25bcc8..1e98ea1f6cdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,11 @@ sha256sums=('6bd6f79ecb88fb857bea7e89c767a3bd0f413ff01bae9298dd2e563478947897'
'828aaf27696ffe2aa4b80755a09bdf264f644d9539366981697a73bb23340d7b'
'f3031ea8217e01ba42cea14606169e3e27affa5918968ffd5a03c21ae92fe2b8')
+prepare() {
+ cd ${_pkgbase}-$pkgver
+ patch -p1 -i ../../fix_ssl_check.patch
+}
+
build() {
cd "${srcdir}"
[[ ! -d build ]] && mkdir build
diff --git a/fix_ssl_check.patch b/fix_ssl_check.patch
new file mode 100644
index 000000000000..106ad43a8b36
--- /dev/null
+++ b/fix_ssl_check.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -484,6 +484,8 @@
+ # a small test program checking the defines. This works for both Qt4 and Qt5.
+ cmake_push_check_state(RESET)
+ set(CMAKE_REQUIRED_INCLUDES ${QT_INCLUDES} ${Qt5Core_INCLUDE_DIRS})
++set(CMAKE_POSITION_INDEPENDENT_CODE)
++set(CMAKE_REQUIRED_FLAGS "-fPIC")
+ check_cxx_source_compiles("
+ #include \"qglobal.h\"
+ #if defined QT_NO_OPENSSL || defined QT_NO_SSL