summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Andreyev2020-04-09 01:20:26 +0300
committerAlexey Andreyev2020-04-09 01:20:26 +0300
commit4099d37e7c478d7c9a9a6b6e468eaf2cbc6b245c (patch)
treeb734695b8efb14b9c1f7d9ccb6ce441f62160f3b
parent0a74013d71daf6b4bee6f1ffd37ddeb69b76534a (diff)
downloadaur-4099d37e7c478d7c9a9a6b6e468eaf2cbc6b245c.tar.gz
Update to 0.0.9.4e
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
2 files changed, 11 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2713f680b71..1c3e1b0ad802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = quaternion
pkgdesc = Qt5-based IM client for the Matrix protocol
- pkgver = 0.0.9.4b
+ pkgver = 0.0.9.4e
pkgrel = 1
url = https://matrix.org/docs/projects/client/quaternion.html
arch = i686
@@ -11,12 +11,11 @@ pkgbase = quaternion
depends = qt5-multimedia
depends = qt5-quickcontrols
depends = qt5-quickcontrols2
+ depends = libQuotient>=0.5.3.2
provides = quaternion
conflicts = quaternion-git
- source = https://github.com/quotient-im/Quaternion/archive/0.0.9.4b.tar.gz
- source = https://github.com/quotient-im/libQuotient/archive/0.5.2.tar.gz
- sha256sums = fc3634a02d12070290c42dc21746ca8e51303eb3ed1cc5e3f6bebf1096b75d1f
- sha256sums = 1848bc0af53ce42c2b1a1a4fdeccb054af1f9e0f765cadf609f62727ce23dfd2
+ source = https://github.com/quotient-im/Quaternion/archive/0.0.9.4e.tar.gz
+ sha256sums = e489f331b49f18e0554b60070e61b7c9
pkgname = quaternion
diff --git a/PKGBUILD b/PKGBUILD
index 4f6c52f58424..a0be438de923 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,22 @@
-# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
+# Maintainer: Alexey Andreyev <aa13q@ya.ru>
+# Contributor: Aleksandar Trifunović <akstrfn at gmail dot com>
# Contributor: Ivan Semkin <ivan at semkin dot ru>
# Contributor: Martin Weinelt <hexa at darmstadt dot ccc dot de>
_appname=Quaternion
pkgname=quaternion
-_libname=libQuotient
-pkgver=0.0.9.4b
-_libquotient_pkgver=0.5.2
+pkgver=0.0.9.4e
pkgrel=1
pkgdesc='Qt5-based IM client for the Matrix protocol'
url='https://matrix.org/docs/projects/client/quaternion.html'
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('qt5-tools' 'qt5-multimedia' 'qt5-quickcontrols' 'qt5-quickcontrols2')
+depends=('qt5-tools' 'qt5-multimedia' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'libQuotient>=0.5.3.2')
makedepends=('cmake')
provides=('quaternion')
conflicts=('quaternion-git')
-source=("https://github.com/quotient-im/Quaternion/archive/$pkgver.tar.gz"
- "https://github.com/quotient-im/libQuotient/archive/${_libquotient_pkgver}.tar.gz")
-sha256sums=('fc3634a02d12070290c42dc21746ca8e51303eb3ed1cc5e3f6bebf1096b75d1f'
- '1848bc0af53ce42c2b1a1a4fdeccb054af1f9e0f765cadf609f62727ce23dfd2')
-
-prepare() {
- cp -r ${_libname}-${_libquotient_pkgver}/* ${srcdir}/${_appname}-${pkgver}/lib/
- # INSTALL rule also installs libqmatrixclient
- sed -i 's/EXCLUDE_FROM_ALL//' ${_appname}-${pkgver}/CMakeLists.txt
-}
+source=("https://github.com/quotient-im/Quaternion/archive/$pkgver.tar.gz")
+sha256sums=('e489f331b49f18e0554b60070e61b7c9')
build() {
cd ${_appname}-${pkgver}
@@ -36,7 +27,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=ON \
- -DUSE_INTREE_LIBQMC=ON
+ -DUSE_INTREE_LIBQMC=OFF
cmake --build build
}