summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtto Sabart2019-12-15 14:09:38 +0100
committerOtto Sabart2019-12-15 14:10:05 +0100
commit46bb6bfa1aa146b24c50f7fdee2f16671af7ca26 (patch)
tree4e4eb2ebe8f468b17c225a2706fc97ed441c5120
downloadaur-46bb6bfa1aa146b24c50f7fdee2f16671af7ca26.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--Makefile10
-rw-r--r--PKGBUILD34
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f7d4aecbb6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qubes-gpg-split
+ pkgdesc = Split GPG implements a concept similar to having a smart card with your private GPG keys, except that the role of the “smart card” plays another Qubes AppVM.
+ pkgver = 2.0.42
+ pkgrel = 1
+ url = https://qubes-os.org
+ arch = x86_64
+ license = GPL
+ makedepends = pkg-config
+ makedepends = make
+ makedepends = gcc
+ makedepends = pandoc
+ depends = gnupg
+ depends = zenity
+ source = https://github.com/QubesOS/qubes-app-linux-split-gpg/archive/v2.0.42.tar.gz
+ sha512sums = 9ddfd499c0e1f18d5f0fbbf1ae6aadbc494dee39aaa796687a0773cf02ef6736db3f17dda456f5632312246c6441eb699ec7dd53146cc2a84ca78b3a450db6cd
+
+pkgname = qubes-gpg-split
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..84ba7be9e23d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+.PHONY: all help clean
+
+all: help
+
+help:
+ @echo "help - print this help message"
+ @echo "clean - clean this repository"
+
+clean:
+ rm -rfv ./src ./pkg ./v*.tar.gz ./*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52e6887860f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Otto Sabart <aur@seberm.com>
+# Contributor: Jacob Jenner Rasmussen <jacob@jener.dk>
+
+# Ref.: https://github.com/QubesOS/qubes-app-linux-split-gpg/blob/master/archlinux/PKGBUILD
+
+pkgname=qubes-gpg-split
+pkgver=2.0.42
+pkgrel=1
+pkgdesc="Split GPG implements a concept similar to having a smart card with your private GPG keys, except that the role of the “smart card” plays another Qubes AppVM."
+arch=("x86_64")
+url="https://qubes-os.org"
+license=('GPL')
+depends=('gnupg' 'zenity')
+makedepends=(pkg-config make gcc pandoc)
+
+source=(https://github.com/QubesOS/qubes-app-linux-split-gpg/archive/v${pkgver}.tar.gz)
+sha512sums=('9ddfd499c0e1f18d5f0fbbf1ae6aadbc494dee39aaa796687a0773cf02ef6736db3f17dda456f5632312246c6441eb699ec7dd53146cc2a84ca78b3a450db6cd')
+
+_srcname=qubes-app-linux-split-gpg-${pkgver}
+
+
+build() {
+ cd "$srcdir/$_srcname/"
+ cd "src/"
+ make
+}
+
+package() {
+ cd "$srcdir/$_srcname/"
+ make install-vm DESTDIR=$pkgdir
+
+ # Archlinux packaging guidelines: /var/run is a symlink to a tmpfs. Don't create it.
+ rm -r "${pkgdir}/var/run"
+}