summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Czernia2020-04-22 19:06:15 +0200
committerNils Czernia2020-04-22 19:06:15 +0200
commit1ade0149c75a9d29be6be21463bc5810d7d0bb0f (patch)
tree7a4dd22045d1da6fb50fd6b8b7d3fcb5b7fa9244
parent0bf858a27c5687af9b963ec39dbb33411d960af6 (diff)
downloadaur-1ade0149c75a9d29be6be21463bc5810d7d0bb0f.tar.gz
Updated to 0.0.20 RC2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--issue710.patch17
3 files changed, 8 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8510ac2aec17..8d529ba87523 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sat Jun 16 10:08:45 UTC 2018
pkgbase = qucs
pkgdesc = An integrated circuit simulator with a graphical user interface
- pkgver = 0.0.19
- pkgrel = 2
+ pkgver = 0.0.20_rc2
+ pkgrel = 1
url = http://qucs.sourceforge.net
arch = x86_64
license = GPL
@@ -13,10 +11,8 @@ pkgbase = qucs
depends = adms
optdepends = freehdl: to permit digital circuit simulation
optdepends = perl
- source = http://downloads.sourceforge.net/project/qucs/qucs/0.0.19/qucs-0.0.19.tar.gz
- source = issue710.patch
- sha256sums = 45c6434fde24c533e63550675ac21cdbd3cc6cbba29b82a1dc3f36e7dd4b3b3e
- sha256sums = 9c396e2fcc835164df8de76eb1689e3480fbf4729d9971054617fd57f48c43db
+ source = http://downloads.sourceforge.net/project/qucs/qucs/0.0.20/qucs-0.0.20-rc2.tar.gz
+ sha256sums = 66cfa0b9f8baa8468feb81b3a15f165e1946511893fa9cfee7009167daa04d19
pkgname = qucs
diff --git a/PKGBUILD b/PKGBUILD
index 82174ed90164..7732fe6ed73e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
- $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
# Maintainer: Nils Czernia <nils[at]czserver.de>
# Contributor: Víctor Martínez Romanos <vmromanos@gmail.com>
pkgname=qucs
-pkgver=0.0.19
-pkgrel=2
+pkgver=0.0.20_rc2
+pkgrel=1
pkgdesc="An integrated circuit simulator with a graphical user interface"
arch=('x86_64')
url="http://qucs.sourceforge.net"
@@ -14,15 +13,8 @@ makedepends=('gperf')
optdepends=('freehdl: to permit digital circuit simulation'
# 'asco: to enable circuit optimization'
'perl')
-source=("http://downloads.sourceforge.net/project/qucs/qucs/$pkgver/qucs-$pkgver.tar.gz"
- "issue710.patch")
-sha256sums=('45c6434fde24c533e63550675ac21cdbd3cc6cbba29b82a1dc3f36e7dd4b3b3e'
- '9c396e2fcc835164df8de76eb1689e3480fbf4729d9971054617fd57f48c43db')
-
-prepare() {
- cd "$srcdir"/$pkgname-${pkgver/s/.}
- patch -p0 -i ../issue710.patch
-}
+source=("http://downloads.sourceforge.net/project/qucs/qucs/${pkgver%_*}/qucs-${pkgver//_/-}.tar.gz")
+sha256sums=('66cfa0b9f8baa8468feb81b3a15f165e1946511893fa9cfee7009167daa04d19')
build() {
cd "$srcdir"/$pkgname-${pkgver/s/.}
diff --git a/issue710.patch b/issue710.patch
deleted file mode 100644
index 1e1806aace45..000000000000
--- a/issue710.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- qucs-core/src/net.cpp
-+++ qucs-core/src/net.cpp
-@@ -350,7 +350,13 @@ void net::orderAnalysis (void) {
- void net::sortChildAnalyses (analysis * parent) {
- ptrlist<analysis> * alist = parent->getAnalysis ();
- if (alist != nullptr) {
-- for (auto *a: *alist) {
-+
-+ for (auto it = alist->begin(); it != alist->end(); /* empty */) {
-+ // Copy the value of the element (a pointer), and advance the
-+ // iterator prior to manipulating the list.
-+ analysis *a = *it;
-+ ++it;
-+
- if (a->getType () == ANALYSIS_DC
- || containsAnalysis (a, ANALYSIS_DC)) {
- parent->delAnalysis (a);