summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwatermelon2022-11-15 10:12:38 +0800
committerwatermelon2022-11-15 10:12:38 +0800
commit8fdef11e746afd955eb9c910ad4644d87fa588c5 (patch)
tree4c0b2c24ada3b6201bea50f0e1c36a46791761ee
parentd216f428b8ace527005be48c31f00fed4cb06a1a (diff)
downloadaur-8fdef11e746afd955eb9c910ad4644d87fa588c5.tar.gz
1.0.0 updated
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b37657506f8d..2068dd60daf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,20 @@
pkgbase = qucs-s
pkgdesc = A spin-off of Qucs that supports other free SPICE circuit simulators like ngspice with the same Qucs GUI
- pkgver = 0.0.24
+ pkgver = 1.0.0
pkgrel = 1
url = https://ra3xdh.github.io
arch = x86_64
arch = i686
license = GPL
makedepends = cmake
- makedepends = autoconf
- makedepends = automake
- makedepends = perl-gd
- makedepends = perl-xml-libxml
- makedepends = gperf
- makedepends = libtool
- makedepends = flex
- makedepends = bison
makedepends = qt5-tools
- makedepends = qt5-script
- makedepends = qt5-svg
- depends = qt5-base
+ depends = qt5-svg
optdepends = ngspice: recommended simulation backend
optdepends = qucs: for Qucsator simulation backend
- optdepends = freehdl: to permit digital circuit simulation
- optdepends = asco: to enable circuit optimization
+ optdepends = xyce-serial: a SPICE-compatible simulation backend
+ optdepends = spiceopus: a general purpose simulation backend for optimization loops
options = !makeflags
- source = https://github.com/ra3xdh/qucs_s/releases/download/0.0.24/qucs-s-0.0.24.tar.gz
- sha256sums = ba7cf6fb06babbddcbb7d4eae0437df4e36346b7cc39a84af62f1643d7e8f296
+ source = https://github.com/ra3xdh/qucs_s/releases/download/1.0.0/qucs-s-1.0.0.tar.gz
+ sha256sums = fc8d446a52dd4730ccba021df8f8a5331d22e1a26edd5d853c2d16518d32953f
pkgname = qucs-s
diff --git a/PKGBUILD b/PKGBUILD
index 1d38f1bf4c28..c73592199863 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
# Contributor: Philip <philip1731 protonmail ch>
pkgname=qucs-s
-pkgver=0.0.24
+pkgver=1.0.0
pkgrel=1
pkgdesc="A spin-off of Qucs that supports other free SPICE circuit simulators like ngspice with the same Qucs GUI"
arch=('x86_64' 'i686')
url="https://ra3xdh.github.io"
license=('GPL')
options=(!makeflags)
-depends=('qt5-base')
-makedepends=('cmake' 'autoconf' 'automake' 'perl-gd' 'perl-xml-libxml' 'gperf' 'libtool' 'flex' 'bison' 'qt5-tools' 'qt5-script' 'qt5-svg')
+depends=('qt5-svg')
+makedepends=('cmake' 'qt5-tools')
optdepends=('ngspice: recommended simulation backend'
'qucs: for Qucsator simulation backend'
- 'freehdl: to permit digital circuit simulation'
- 'asco: to enable circuit optimization'
+ 'xyce-serial: a SPICE-compatible simulation backend'
+ 'spiceopus: a general purpose simulation backend for optimization loops'
)
source=(https://github.com/ra3xdh/qucs_s/releases/download/$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('ba7cf6fb06babbddcbb7d4eae0437df4e36346b7cc39a84af62f1643d7e8f296')
+sha256sums=('fc8d446a52dd4730ccba021df8f8a5331d22e1a26edd5d853c2d16518d32953f')
build() {
cd $srcdir/$pkgname-$pkgver