summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWatermelon Rei2024-03-27 20:07:36 +0800
committerWatermelon Rei2024-03-27 20:07:36 +0800
commitb02c35bc781dd44b8e07733224e8015bf4277505 (patch)
tree5533b7a70a69bd1df820caeeb683be5f78f8b914
parente76a94758c34ef5a26d39e1f5d2bd4d5ddfdec8e (diff)
downloadaur-b02c35bc781dd44b8e07733224e8015bf4277505.tar.gz
add CMake flag for QT6 suppport
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4cbc55747c6..233edb560260 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qucs-s
pkgdesc = A spin-off of Qucs that supports other free SPICE circuit simulators like ngspice with the same Qucs GUI
pkgver = 24.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://ra3xdh.github.io
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 244cee4b7e3c..054dee907c00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=qucs-s
pkgver=24.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A spin-off of Qucs that supports other free SPICE circuit simulators like ngspice with the same Qucs GUI"
arch=('x86_64' 'i686')
url="https://ra3xdh.github.io"
@@ -21,12 +21,12 @@ source=(https://github.com/ra3xdh/qucs_s/releases/download/$pkgver/$pkgname-$pkg
sha256sums=('14d8d81793ec846c03469cdba0a7eeaa6f12182242166c0b62762b62f34c45da')
build() {
- export QT_DIR=/usr/lib/cmake/Qt6/
cd $srcdir/$pkgname-$pkgver
mkdir -p builddir
cd builddir
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_QT6=ON \
..
make -j$(nproc)
}