summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip2022-04-08 18:51:25 +0800
committerPhilip2022-04-08 18:51:25 +0800
commitf6bf67a777a1d5605f2394a62d03d2715d590d42 (patch)
tree556ace4a834342de28ad081c1043e9397be5ab25
parentf098e955737029bac6f0d3af2fb834215a169df0 (diff)
downloadaur-f6bf67a777a1d5605f2394a62d03d2715d590d42.tar.gz
Updated PKGBUILD for Qucs-S-0.0.23
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fb120e52ca0..723ffdf3d3f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qucs-s
pkgdesc = A spin-off of Qucs that supports other free SPICE circuit simulators like ngspice with the same Qucs GUI
- pkgver = 0.0.22
+ pkgver = 0.0.23
pkgrel = 1
url = https://ra3xdh.github.io
arch = x86_64
@@ -15,14 +15,15 @@ pkgbase = qucs-s
makedepends = libtool
makedepends = flex
makedepends = bison
- depends = qt4
+ makedepends = qt5-tools
+ makedepends = qt5-script
+ depends = qt5-base
optdepends = ngspice: recommended simulation backend
optdepends = qucs: for Qucsator simulation backend
optdepends = freehdl: to permit digital circuit simulation
optdepends = asco: to enable circuit optimization
options = !makeflags
- source = https://github.com/ra3xdh/qucs_s/releases/download/0.0.22/qucs-s-0.0.22.tar.gz
- sha1sums = ea86b172145e61a45fd588516ee51dae7555c866
+ source = https://github.com/ra3xdh/qucs_s/releases/download/0.0.23/qucs-s-0.0.23.tar.gz
+ sha256sums = 6d2ba31d471cbd05fbc799e09b88f1bd4351cfed228883944968c771463e9376
pkgname = qucs-s
-
diff --git a/PKGBUILD b/PKGBUILD
index ca93d850321c..ee5ea4c870cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Maintainer: sytabaresa <sytabaresa@gmail.com>
+# Maintainer: Philip <philip1731 protonmail ch>
pkgname=qucs-s
-pkgver=0.0.22
+pkgver=0.0.23
pkgrel=1
pkgdesc="A spin-off of Qucs that supports other free SPICE circuit simulators like ngspice with the same Qucs GUI"
arch=('x86_64' 'i686')
url="https://ra3xdh.github.io"
license=('GPL')
options=(!makeflags)
-depends=('qt4')
-makedepends=('cmake' 'autoconf' 'automake' 'perl-gd' 'perl-xml-libxml' 'gperf' 'libtool' 'flex' 'bison')
+depends=('qt5-base')
+makedepends=('cmake' 'autoconf' 'automake' 'perl-gd' 'perl-xml-libxml' 'gperf' 'libtool' 'flex' 'bison' 'qt5-tools' 'qt5-script')
optdepends=('ngspice: recommended simulation backend'
'qucs: for Qucsator simulation backend'
'freehdl: to permit digital circuit simulation'
'asco: to enable circuit optimization'
)
source=(https://github.com/ra3xdh/qucs_s/releases/download/$pkgver/$pkgname-$pkgver.tar.gz)
-sha1sums=('ea86b172145e61a45fd588516ee51dae7555c866')
+sha256sums=('6d2ba31d471cbd05fbc799e09b88f1bd4351cfed228883944968c771463e9376')
build() {
cd $srcdir/$pkgname-$pkgver
- mkdir builddir
+ mkdir -p builddir
cd builddir
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make