summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2015-06-24 10:47:07 +0200
committerzoe2015-06-24 10:47:07 +0200
commitbfeecb3fc4643199ebd401e842ffcbf96a2be2d7 (patch)
treee327622ab51e78c7a03de4f47d29edff36ba33dd
downloadaur-bfeecb3fc4643199ebd401e842ffcbf96a2be2d7.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03f2b41111db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = quelcom
+ pkgdesc = Quelcom provides assorted tools to perform simple editing operations on MP3 and WAV audio files. These include fading, check-and-clean, informational extraction and lossless cutting and joining without reencoding.
+ pkgver = 0.4.0
+ pkgrel = 13
+ url = http://packages.ubuntu.com/trusty/sound/quelcom
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://mirrors.kernel.org/ubuntu/pool/universe/q/quelcom/quelcom_0.4.0-13_amd64.deb
+ md5sums = a29966b510401c2504f23ba27e2ae2db
+
+pkgname = quelcom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..270feddea5de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Vithon <ratm@archlinux.us>
+# Maintainer: Zoe <chp321@gmail.com>
+pkgname=quelcom
+pkgver=0.4.0
+pkgrel=13
+pkgdesc="Quelcom provides assorted tools to perform simple editing operations on MP3 and WAV audio files. These include fading, check-and-clean, informational extraction and lossless cutting and joining without reencoding."
+license=('GPL')
+url="http://packages.ubuntu.com/trusty/sound/quelcom"
+arch=('i686' 'x86_64')
+if [[ `uname -m` = 'x86_64' ]]; then
+ _arch='amd64'
+ source=('http://mirrors.kernel.org/ubuntu/pool/universe/q/quelcom/quelcom_0.4.0-13_amd64.deb')
+ md5sums=('a29966b510401c2504f23ba27e2ae2db')
+elif [[ `uname -m` = 'i686' ]]; then
+ _arch='i386'
+ source=('http://mirrors.kernel.org/ubuntu/pool/universe/q/quelcom/quelcom_0.4.0-13_i386.deb')
+ md5sums=('de6890247ea09b7f262f9ded563e7935')
+fi
+
+
+build() {
+ cd $srcdir
+
+ bsdtar xf "${pkgname}_${pkgver}-${pkgrel}_${_arch}.deb" || return 1
+ bsdtar xf data.tar.gz -C $pkgdir || return 1
+}