summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKasei Wang2019-10-11 10:37:50 +0800
committerKasei Wang2019-10-11 10:37:50 +0800
commit4878d500cd50ac6963023870686e9fabe4e7c96b (patch)
treeae567c9cca58a1a9f2a2865557ae8beef9c6ce6e
parent04b3660cfc36a168dd79821957fc689485b71772 (diff)
downloadaur-4878d500cd50ac6963023870686e9fabe4e7c96b.tar.gz
updpkg: quiche 0.1.0-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4b5281ba6b7..6a0392cd4def 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = quiche
- pkgdesc = quiche is an implementation of the QUIC transport protocol and HTTP/3 as specified by the IETF
+ pkgdesc = an implementation of the QUIC transport protocol and HTTP/3 as specified by the IETF
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cloudflare/quiche
arch = x86_64
license = custom:BSD
- makedepends = rust
+ makedepends = cmake
makedepends = git
+ makedepends = go
+ makedepends = rust
depends = gcc-libs
source = https://github.com/cloudflare/quiche/archive/0.1.0.tar.gz
source = git+https://boringssl.googlesource.com/boringssl#branch=chromium-stable
diff --git a/PKGBUILD b/PKGBUILD
index 8cf94c812ac8..d9355d498966 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Mnaintainer: Kasei Wang <kasei@kasei.im>
+# Maintainer: Kasei Wang <kasei@kasei.im>
pkgname=quiche
pkgver=0.1.0
-pkgrel=1
-pkgdesc='quiche is an implementation of the QUIC transport protocol and HTTP/3 as specified by the IETF'
+pkgrel=2
+pkgdesc='an implementation of the QUIC transport protocol and HTTP/3 as specified by the IETF'
arch=('x86_64')
url='https://github.com/cloudflare/quiche'
license=('custom:BSD')
depends=('gcc-libs')
-makedepends=('rust' 'git')
+makedepends=('cmake' 'git' 'go' 'rust')
source=("https://github.com/cloudflare/$pkgname/archive/$pkgver.tar.gz"
"git+https://boringssl.googlesource.com/boringssl#branch=chromium-stable")
sha256sums=('6a369615005b8f1e361bfaca5ec07989443ab1b62af60a07ac41f63ff4b7d1af'
@@ -31,9 +31,11 @@ package() {
mkdir -p $pkgdir/usr/include
mkdir -p $pkgdir/usr/lib
mkdir -p $pkgdir/usr/lib/pkgconfig
+ mkdir -p $pkgdir/usr/share/licenses/quiche
install include/quiche.h $pkgdir/usr/include
install target/release/libquiche.a $pkgdir/usr/lib
install target/release/libquiche.so $pkgdir/usr/lib
install target/release/quiche.pc $pkgdir/usr/lib/pkgconfig
+ install COPYING $pkgdir/usr/share/licenses/quiche
}