aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew "strager" Glazar2021-05-19 17:56:26 -0700
committerMatthew "strager" Glazar2021-05-19 17:57:27 -0700
commit04de9b382f2a376a31fdc88e18a7c61841c0aaa1 (patch)
tree3b15ba6513bdd955e0aec9ecd079231bce15748d
downloadaur-04de9b382f2a376a31fdc88e18a7c61841c0aaa1.tar.gz
Add quick-lint-js version 0.2.0
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD64
-rw-r--r--README4
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..989734ddc21d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = quick-lint-js
+ pkgdesc = Find bugs in JavaScript programs
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://quick-lint-js.com/
+ arch = aarch64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ license = Apache
+ license = Boost
+ license = GPL3
+ checkdepends = icu
+ makedepends = cmake
+ makedepends = ninja
+ depends = gcc-libs
+ conflicts = quick-lint-js
+ source = quick-lint-js-0.2.0.tar.gz::https://github.com/quick-lint/quick-lint-js/archive/refs/tags/0.2.0.tar.gz
+ sha512sums = dddc90c73ffb5b35473d477a2758d73e6ad84810085139393dc55a6ccc39d3138aeea742f41eaa8ffd308dc189e1d28e0724c1601ee4e752706c47c63c697244
+
+pkgname = quick-lint-js
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..33662f5545b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad9cc77dd16d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Copyright (C) 2020 Matthew Glazar
+# See end of file for extended copyright information.
+
+# Maintainer: Matthew "strager" Glazar <strager.nds@gmail.com>
+# Contributor: Shivam Mehta <sm.cse at gmail dot com>
+
+pkgname=quick-lint-js
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Find bugs in JavaScript programs"
+arch=(aarch64 arm armv6h armv7h i686 pentium4 x86_64)
+url="https://quick-lint-js.com/"
+license=(Apache Boost GPL3)
+depends=(gcc-libs)
+makedepends=(cmake ninja)
+checkdepends=(icu)
+provides=()
+conflicts=(quick-lint-js)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/quick-lint/${pkgname}/archive/refs/tags/${pkgver}.tar.gz")
+sha512sums=('dddc90c73ffb5b35473d477a2758d73e6ad84810085139393dc55a6ccc39d3138aeea742f41eaa8ffd308dc189e1d28e0724c1601ee4e752706c47c63c697244')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cmake -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQUICK_LINT_JS_INSTALL_LICENSES_DIR="share/licenses/${pkgname}" \
+ -S . -B build
+ ninja -C build
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ ninja -C build test
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}/" ninja -C build install
+
+ # TODO(strager): Remove the following after releasing a new version:
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}/"
+ mv "${pkgdir}/usr/share/doc/quick-lint-js/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/copyright"
+ rmdir "${pkgdir}/usr/share/doc/quick-lint-js/"
+ rmdir "${pkgdir}/usr/share/doc/"
+}
+
+# quick-lint-js finds bugs in JavaScript programs.
+# Copyright (C) 2020 Matthew Glazar
+#
+# This file is part of quick-lint-js.
+#
+# quick-lint-js is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# quick-lint-js is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with quick-lint-js. If not, see <https://www.gnu.org/licenses/>.
diff --git a/README b/README
new file mode 100644
index 000000000000..e997f1ab023e
--- /dev/null
+++ b/README
@@ -0,0 +1,4 @@
+This directory contains the quick-lint-js package.
+
+The PKGBUILD file is copied from quick-lint-js' repository:
+https://github.com/quick-lint/quick-lint-js/blob/0486214b8aca7eb0bb90bf4d3a526529c4002597/dist/arch/PKGBUILD-release