aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew "strager" Glazar2021-05-19 18:35:25 -0700
committerMatthew "strager" Glazar2021-05-19 18:35:25 -0700
commit13f99fb894feceb3a2d83bc4c1d2cf541f13e051 (patch)
tree3ff78d326af715568177e6427f9b2d91ce80a3c0
downloadaur-13f99fb894feceb3a2d83bc4c1d2cf541f13e051.tar.gz
Add quick-lint-js-git (latest from VCS)
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD63
-rw-r--r--README4
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..662e519cff08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = quick-lint-js-git
+ pkgdesc = Find bugs in JavaScript programs
+ pkgver = 0.2.0.r309.g0486214b
+ pkgrel = 1
+ url = https://quick-lint-js.com/
+ arch = aarch64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ license = Apache
+ license = Boost
+ license = GPL3
+ checkdepends = icu
+ makedepends = cmake
+ makedepends = git
+ makedepends = ninja
+ depends = gcc-libs
+ provides = quick-lint-js
+ conflicts = quick-lint-js
+ source = quick-lint-js::git+https://github.com/quick-lint/quick-lint-js.git
+ sha256sums = SKIP
+
+pkgname = quick-lint-js-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..33662f5545b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be911e9433f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Copyright (C) 2020 Matthew Glazar
+# See end of file for extended copyright information.
+
+# Maintainer: Matthew "strager" Glazar <strager.nds@gmail.com>
+# Contributor: Shivam Mehta <sm.cse at gmail dot com>
+
+pkgname=quick-lint-js-git
+pkgver=0.2.0.r309.g0486214b
+pkgrel=1
+pkgdesc="Find bugs in JavaScript programs"
+arch=(aarch64 arm armv6h armv7h i686 pentium4 x86_64)
+url="https://quick-lint-js.com/"
+license=(Apache Boost GPL3)
+depends=(gcc-libs)
+makedepends=(cmake git ninja)
+checkdepends=(icu)
+provides=(quick-lint-js)
+conflicts=(quick-lint-js)
+source=(quick-lint-js::git+https://github.com/quick-lint/quick-lint-js.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd quick-lint-js
+ git describe --long --tags | sed -e 's/-/-r/; s/-/./g'
+}
+
+build() {
+ cd quick-lint-js
+ cmake -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQUICK_LINT_JS_INSTALL_LICENSES_DIR="share/licenses/${pkgname}" \
+ -S . -B build
+ ninja -C build
+}
+
+check() {
+ cd quick-lint-js
+ ninja -C build test
+}
+
+package() {
+ cd quick-lint-js
+ DESTDIR="${pkgdir}/" ninja -C build install
+}
+
+# quick-lint-js finds bugs in JavaScript programs.
+# Copyright (C) 2020 Matthew Glazar
+#
+# This file is part of quick-lint-js.
+#
+# quick-lint-js is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# quick-lint-js is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with quick-lint-js. If not, see <https://www.gnu.org/licenses/>.
diff --git a/README b/README
new file mode 100644
index 000000000000..541df381f43f
--- /dev/null
+++ b/README
@@ -0,0 +1,4 @@
+This directory contains the quick-lint-js-git package.
+
+The PKGBUILD file is copied from quick-lint-js' repository:
+https://github.com/quick-lint/quick-lint-js/blob/0486214b8aca7eb0bb90bf4d3a526529c4002597/dist/arch/PKGBUILD-git