summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kutka2021-05-14 20:28:29 +0200
committerDaniel Kutka2021-05-14 20:28:29 +0200
commit65c2a6f77fc0f4cd521d9e00c30475cbefbf0796 (patch)
tree5e13553d4dcbdd07e37bc5a4655c698331afaf12
parenta477aaa8a329626e97798d2e1a7909fad3fa8601 (diff)
downloadaur-65c2a6f77fc0f4cd521d9e00c30475cbefbf0796.tar.gz
Release 1.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34252a6cab05..53d460e9127c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = quickddit
pkgdesc = Unofficial reddit client
- pkgver = 1.1
- pkgrel = 5
+ pkgver = 1.2
+ pkgrel = 0
url = https://github.com/accumulator/Quickddit.git
arch = x86_64
arch = armv7
@@ -13,10 +13,12 @@ pkgbase = quickddit
depends = qt5-quickcontrols2
depends = qt5-webengine
depends = youtube-dl
- depends = qqc2-suru-style
- depends = python-pyotherside
- depends = qt5-graphicaleffects
- source = git+https://github.com/dano6/Quickddit.git#branch=flavors
+ depends = python-pyotherside
+ depends = qt5-graphicaleffects
+ optdepends = qqc2-suru-style-git: Suru style
+ optdepends = qqc2-breeze-style: Breeze style
+ optdepends = qqc2-desktop-style: KDE desktop style
+ source = git+https://github.com/dano6/Quickddit.git#branch=5.12
md5sums = SKIP
pkgname = quickddit
diff --git a/PKGBUILD b/PKGBUILD
index 5da428846c68..380083320055 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,25 @@
pkgname=quickddit
_pkgname=Quickddit
-pkgver=1.1
-pkgrel=5
+pkgver=1.2
+pkgrel=0
pkgdesc="Unofficial reddit client"
arch=('x86_64' 'armv7' 'aarch64')
url="https://github.com/accumulator/Quickddit.git"
license=('GPL3')
-depends=(qt5-base qt5-declarative qt5-quickcontrols2 qt5-webengine youtube-dl qqc2-suru-style python-pyotherside qt5-graphicaleffects)
+depends=(qt5-base qt5-declarative qt5-quickcontrols2 qt5-webengine youtube-dl python-pyotherside qt5-graphicaleffects)
makedepends=('git')
-source=('git+https://github.com/dano6/Quickddit.git#branch=flavors')
+source=('git+https://github.com/dano6/Quickddit.git#branch=5.12')
md5sums=('SKIP')
+optdepends=('qqc2-suru-style-git: Suru style'
+ 'qqc2-breeze-style: Breeze style'
+ 'qqc2-desktop-style: KDE desktop style'
+)
+
prepare() {
cd ${_pkgname}
- git submodule update --init
+ git submodule update --init qt-json
}