summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWesley Moore2018-05-09 10:34:07 +1000
committerWesley Moore2018-05-09 10:34:07 +1000
commit8594527b375f2256f8d20487e985642ba3d3d26e (patch)
tree155d184a8b49ecaeeff38174a2f8acda2e560e65
downloadaur-8594527b375f2256f8d20487e985642ba3d3d26e.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD24
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8af70d3556e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = quickdocs
+ pkgdesc = GTK app for reading Valadoc and DevDocs
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/mdh34/quickDocs
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = desktop-file-utils
+ makedepends = hicolor-icon-theme
+ makedepends = intltool
+ makedepends = yelp-tools
+ makedepends = gnome-common
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vala
+ depends = glib2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = vala
+ depends = webkit2gtk
+ depends = devhelp
+ depends = libarchive
+ options = !libtool
+ source = https://github.com/mdh34/quickdocs/archive/2.0.1.tar.gz
+ sha256sums = 460f0a9e1f9566245494700e17bf5ae3996a79007e025e3966b067989dbb2013
+
+pkgname = quickdocs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff4a654fe69c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Wesley Moore <wes@wezm.net>
+pkgname="quickdocs"
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="GTK app for reading Valadoc and DevDocs"
+arch=('x86_64')
+url="https://github.com/mdh34/quickDocs"
+license=('GPL3')
+depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'vala' 'webkit2gtk' 'devhelp' 'libarchive')
+makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection' 'meson' 'ninja' 'vala')
+options=('!libtool')
+source=("https://github.com/mdh34/$pkgname/archive/${pkgver//_/-}.tar.gz")
+sha256sums=('460f0a9e1f9566245494700e17bf5ae3996a79007e025e3966b067989dbb2013')
+
+build() {
+ cd "${srcdir}/quickDocs-${pkgver}"
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd "${srcdir}/quickDocs-${pkgver}"
+ DESTDIR="${pkgdir}/" ninja -C build install
+}