summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-07-04 00:00:57 +0200
committerFabioLolix2017-07-04 00:00:57 +0200
commit82735c6759c1373dac3166c581760332bec28d1e (patch)
treeae7a1b1a9442936822490b51a02523b3188557ab
downloadaur-82735c6759c1373dac3166c581760332bec28d1e.tar.gz
initial release, version 2.8.2
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD26
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b33e2b43018c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = quickhash-gui-bin
+ pkgdesc = QuickHash is an open-source Linux GUI that enables hashing of files, text, entire folder trees of files, and physical disks
+ pkgver = 2.8.2
+ pkgrel = 1
+ url = http://quickhash-gui.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = gtk2
+ provides = quickhash-gui
+ conflicts = quickhash-gui
+ conflicts = quickhash-gui-bin
+ source = local://QuickHash-v2.8.2-DebianPackages.zip
+ md5sums = de339281c37833f7e0a5f14be248dc56
+
+pkgname = quickhash-gui-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a2b9f39f612a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+*.gz
+*.xz
+*.zip
+*.tar*
+*.tgz
+*.bz2
+*.deb
+*.rpm
+*.run
+pkg
+src
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d81f807db79d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# https://github.com/FabioLolix
+
+pkgname=quickhash-gui-bin
+_pkgname1=QuickHash
+_pkgname2=quickhash
+pkgver=2.8.2
+pkgrel=1
+pkgdesc="QuickHash is an open-source Linux GUI that enables hashing of files, text, entire folder trees of files, and physical disks"
+arch=('i686' 'x86_64')
+url="http://quickhash-gui.org/"
+license=('GPL2')
+depends=('gtk2')
+provides=('quickhash-gui')
+conflicts=('quickhash-gui' 'quickhash-gui-bin')
+source=("local://${_pkgname1}-v$pkgver-DebianPackages.zip")
+md5sums=('de339281c37833f7e0a5f14be248dc56')
+package() {
+if [[ "${CARCH}" = 'i686' ]]; then
+ bsdtar -xf "$_pkgname2"_"$pkgver"-1_i386.deb
+ fi
+if [[ "${CARCH}" = 'x86_64' ]]; then
+ bsdtar -xf "$_pkgname2"_"$pkgver"-1_amd64.deb
+ fi
+bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
+}