summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-08-15 00:07:49 +0200
committerFabioLolix2018-08-15 00:07:49 +0200
commit8df23d20446df2a09bf5f4dfc4fcc0c6e3a26f9c (patch)
tree118d6d74958597cb53426250822020dbdedeb185
parentb5b7cddc419cabf161e6c90391a3afd41cee19dc (diff)
downloadaur-8df23d20446df2a09bf5f4dfc4fcc0c6e3a26f9c.tar.gz
v3.0.2
-rwxr-xr-x[-rw-r--r--].SRCINFO8
-rwxr-xr-x[-rw-r--r--]PKGBUILD26
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea07ef34c6a0..c2d936e3f296 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = quickhash-gui-bin
pkgdesc = QuickHash is an open-source Linux GUI that enables hashing of files, text, entire folder trees of files, and physical disks
- pkgver = 2.8.4
+ pkgver = 3.0.2
pkgrel = 1
- url = http://quickhash-gui.org/
+ url = https://quickhash-gui.org/
arch = i686
arch = x86_64
license = GPL2
@@ -10,8 +10,8 @@ pkgbase = quickhash-gui-bin
provides = quickhash-gui
conflicts = quickhash-gui
conflicts = quickhash-gui-bin
- source = https://sourceforge.net/projects/lolix-remix-of-manjaro/files/AUR_pkg/mirror/quickhash-2.8.4-debian.zip
- md5sums = bd01e2e70218cf25bcf2536e84ae65f5
+ source = quickhash-gui-3.0.2.zip::https://quickhash-gui.org/download/quickhash-v3-0-2-debian-packages-for-linux/?wpdmdl=1658
+ md5sums = 96fb68e77aaac9c91e5943a1463c52c8
pkgname = quickhash-gui-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5f1e856c427e..8f412461ad69 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
-# https://github.com/FabioLolix
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=quickhash-gui-bin
_pkgname=quickhash
-pkgver=2.8.4
+_pkgver=3-0-2
+pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="QuickHash is an open-source Linux GUI that enables hashing of files, text, entire folder trees of files, and physical disks"
-arch=('i686' 'x86_64')
-url="http://quickhash-gui.org/"
-license=('GPL2')
-depends=('gtk2')
-provides=('quickhash-gui')
-conflicts=('quickhash-gui' 'quickhash-gui-bin')
-source=("https://sourceforge.net/projects/lolix-remix-of-manjaro/files/AUR_pkg/mirror/${_pkgname}-$pkgver-debian.zip")
-md5sums=('bd01e2e70218cf25bcf2536e84ae65f5')
+arch=(i686 x86_64)
+url="https://quickhash-gui.org/"
+license=(GPL2)
+depends=(gtk2)
+provides=(quickhash-gui)
+conflicts=(quickhash-gui quickhash-gui-bin)
+source=("quickhash-gui-${pkgver}.zip::https://quickhash-gui.org/download/quickhash-v3-0-2-debian-packages-for-linux/?wpdmdl=1658")
+md5sums=('96fb68e77aaac9c91e5943a1463c52c8')
+
package() {
if [[ "${CARCH}" = 'i686' ]]; then
bsdtar -xf ${_pkgname}_${pkgver}-1_i386.deb
@@ -21,5 +22,6 @@ if [[ "${CARCH}" = 'i686' ]]; then
if [[ "${CARCH}" = 'x86_64' ]]; then
bsdtar -xf ${_pkgname}_${pkgver}-1_amd64.deb
fi
-bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
+
+ bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
}