summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoratomlong2021-10-23 15:09:35 +0800
committeratomlong2021-10-23 15:09:35 +0800
commit4625994c53e6f74b8dee5184088d1b3147b3271c (patch)
treec86d68f5be4a45b6324fd7bad33820e5e30bfaeb
downloadaur-4625994c53e6f74b8dee5184088d1b3147b3271c.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69bd3dd5e876
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = quickjspp
+ pkgdesc = QuickJS C++ wrapper
+ pkgver = 20210913
+ pkgrel = 1
+ url = https://github.com/ftk/quickjspp
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = CC0
+ makedepends = cmake
+ makedepends = git
+ makedepends = gcc
+ source = quickjspp::git+https://github.com/ftk/quickjspp.git
+ sha256sums = SKIP
+
+pkgname = quickjspp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c497f6f54b00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Atom Long <atom.long@hotmail.com>
+
+pkgname=quickjspp
+pkgver=20210913
+pkgrel=1
+pkgdesc='QuickJS C++ wrapper'
+url='https://github.com/ftk/quickjspp'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+license=('CC0')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+makedepends=('cmake' 'git' 'gcc')
+
+pkgver() {
+ cd ${pkgname}
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
+build() {
+ cd ${pkgname}
+ cmake -DCMAKE_BUILD_TYPE=Release .
+ make quickjs
+}
+
+package() {
+ cd ${pkgname}
+ install -Dm644 quickjs/libquickjs.a -t ${pkgdir}/usr/lib/
+ install -Dm644 quickjs/quickjs.h quickjs/quickjs-libc.h -t ${pkgdir}/usr/include/quickjs/
+ install -m644 quickjspp.hpp ${pkgdir}/usr/include/
+}