summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Arms2020-04-30 23:11:03 +1000
committerLuke Arms2020-04-30 23:16:08 +1000
commit0915f32c6af3d2bd73dc90bab2204eb49f6736fe (patch)
tree020bc756819931e3424d6da38b73c823a641dfce
parent0ddbe727feac73352ce2292a0199776542d97c2c (diff)
downloadaur-0915f32c6af3d2bd73dc90bab2204eb49f6736fe.tar.gz
Upgrade to QuickTile 0.4.0 (Python 3, GTK 3, PyGObject)
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
3 files changed, 31 insertions, 50 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 291c428a2d10..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,17 +0,0 @@
-pkgbase = quicktile-git
- pkgdesc = Lightweight standalone alternative to Compiz Grid plugin
- pkgver = 20170907
- pkgrel = 2
- url = https://github.com/ssokolow/quicktile
- arch = any
- license = GPLv2
- makedepends = git
- depends = pygtk
- depends = python2
- depends = python2-setuptools
- depends = python2-wnck
- depends = python2-xlib
- optdepends = python2-dbus
-
-pkgname = quicktile-git
-
diff --git a/.SRCINFO b/.SRCINFO
index 102e82c081d7..0af8207131ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = quicktile-git
- pkgdesc = Lightweight standalone alternative to Compiz Grid plugin
- pkgver = 20170907
- pkgrel = 2
+ pkgdesc = Adds window-tiling hotkeys to any X11 desktop
+ pkgver = 0.4.0
+ pkgrel = 1
+ epoch = 1
url = https://github.com/ssokolow/quicktile
arch = any
license = GPLv2
- makedepends = git
- depends = python2
- depends = pygtk
- depends = python2-xlib
- depends = python2-wnck
- depends = python2-setuptools
- optdepends = python2-dbus
+ makedepends = python-setuptools
+ depends = python
+ depends = gtk3
+ depends = libwnck3
+ depends = python-gobject
+ depends = python-xlib
+ optdepends = python-dbus: required if you want to interact with QuickTile over D-Bus
+ source = https://github.com/ssokolow/quicktile/archive/v0.4.0.tar.gz
+ sha512sums = 4aecbd3433d28872c7c2e9a59eaf0d907a901c29bafa900f76c8f9a074450577522037d89cb6a206807df5f6086c0425da847ec6f26c88431e0bb6183b2631f2
pkgname = quicktile-git
diff --git a/PKGBUILD b/PKGBUILD
index ae1d94c76a71..63666fcc34d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,30 @@
-# Maintainer: dustball
-# Contributor: Luke Arms <luke@arms.to>
+# Maintainer: Luke Arms <luke@arms.to>
+# Contributor: dustball
pkgname=quicktile-git
-pkgver=20200209
+pkgver=0.4.0
pkgrel=1
+epoch=1
url="https://github.com/ssokolow/quicktile"
-pkgdesc="Lightweight standalone alternative to Compiz Grid plugin"
+pkgdesc="Adds window-tiling hotkeys to any X11 desktop"
arch=('any')
license=('GPLv2')
-depends=('python2' 'pygtk' 'python2-xlib' 'python2-wnck' 'python2-setuptools')
-optdepends=('python2-dbus')
-makedepends=('git')
-
-_gitroot='git://github.com/ssokolow/quicktile.git'
-_gitname='quicktile'
+depends=('python' 'gtk3' 'libwnck3' 'python-gobject' 'python-xlib')
+optdepends=('python-dbus: required if you want to interact with QuickTile over D-Bus')
+makedepends=('python-setuptools')
+source=(
+ "https://github.com/ssokolow/quicktile/archive/v${pkgver}.tar.gz"
+)
+sha512sums=(
+ '4aecbd3433d28872c7c2e9a59eaf0d907a901c29bafa900f76c8f9a074450577522037d89cb6a206807df5f6086c0425da847ec6f26c88431e0bb6183b2631f2'
+)
build() {
- cd "$srcdir"
-
- msg "Cloning QuickTile from GIT"
- if [ -d "$_gitname" ]; then
- cd "$_gitname"
- git fetch &&
- git checkout legacy_gtk2 &&
- git pull || return 1
- else
- git clone -b legacy_gtk2 "$_gitroot" "$_gitname" || return 1
- fi
+ cd "$srcdir/${pkgname%-git}-$pkgver"
+ python setup.py build
}
package() {
- cd "$srcdir/$_gitname"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd "$srcdir/${pkgname%-git}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}