summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Arms2020-11-04 10:25:59 +1100
committerLuke Arms2020-11-04 10:37:05 +1100
commitbaa20122a8f5b0d80b80e356e36113c101527de1 (patch)
tree342e798ee394475f1925b6b15ad4caddb7592f33
parentef2572f9af6e19e8e6cb9ece27920342ae36fbbf (diff)
downloadaur-baa20122a8f5b0d80b80e356e36113c101527de1.tar.gz
Resume tracking master branch (separate package now tracks releases)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c2782287a99..62cf51bf44c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = quicktile-git
pkgdesc = Adds window-tiling hotkeys to any X11 desktop
- pkgver = 0.4.0
+ pkgver = 422.ca8105d
pkgrel = 1
epoch = 1
url = https://github.com/ssokolow/quicktile
@@ -13,8 +13,10 @@ pkgbase = quicktile-git
depends = python-gobject
depends = python-xlib
optdepends = python-dbus: required if you want to interact with QuickTile over D-Bus
- source = https://github.com/ssokolow/quicktile/archive/v0.4.0.tar.gz
- sha512sums = 4aecbd3433d28872c7c2e9a59eaf0d907a901c29bafa900f76c8f9a074450577522037d89cb6a206807df5f6086c0425da847ec6f26c88431e0bb6183b2631f2
+ provides = quicktile
+ conflicts = quicktile
+ source = git+https://github.com/ssokolow/quicktile.git
+ sha512sums = SKIP
pkgname = quicktile-git
diff --git a/PKGBUILD b/PKGBUILD
index 328e346d3874..169f97f6e6d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Contributor: dustball
pkgname=quicktile-git
-pkgver=0.4.0
+_pkgname=${pkgname%-git}
+pkgver=422.ca8105d
pkgrel=1
epoch=1
url="https://github.com/ssokolow/quicktile"
@@ -12,19 +13,23 @@ license=('GPL2')
depends=('python' 'gtk3' 'libwnck3' 'python-gobject' 'python-xlib')
optdepends=('python-dbus: required if you want to interact with QuickTile over D-Bus')
makedepends=('python-setuptools')
-source=(
- "https://github.com/ssokolow/quicktile/archive/v${pkgver}.tar.gz"
-)
-sha512sums=(
- '4aecbd3433d28872c7c2e9a59eaf0d907a901c29bafa900f76c8f9a074450577522037d89cb6a206807df5f6086c0425da847ec6f26c88431e0bb6183b2631f2'
-)
+provides=('quicktile')
+conflicts=('quicktile')
+source=("git+https://github.com/ssokolow/quicktile.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf '%s.%s' \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd "$srcdir/${pkgname%-git}-$pkgver"
+ cd "${srcdir}/${_pkgname}"
python setup.py build
}
package() {
- cd "$srcdir/${pkgname%-git}-$pkgver"
+ cd "${srcdir}/${_pkgname}"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}