summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMCotocel2021-04-20 08:44:48 +0400
committerMCotocel2021-04-20 08:44:48 +0400
commit6bcb2e57eef645737838729e93946a2562266ee6 (patch)
tree5254cb0199399c597cbb945b2c03ae7de470437f
downloadaur-6bcb2e57eef645737838729e93946a2562266ee6.tar.gz
Added pkgbuild
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4983e2abb7df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = quiet-gtk-git
+ pkgdesc = Quiet theme for GTK
+ pkgver = r5.28017af
+ pkgrel = 1
+ url = https://github.com/quiettheme/gtk
+ arch = any
+ license = GPL
+ makedepends = git
+ source = git+https://github.com/quiettheme/gtk
+ md5sums = SKIP
+
+pkgname = quiet-gtk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b919c04b9289
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Matei Cotocel <mcotocel at outlook dot com>
+pkgname=quiet-gtk-git
+pkgver=r5.28017af
+pkgrel=1
+pkgdesc="Quiet theme for GTK"
+arch=('any')
+url="https://github.com/quiettheme/gtk"
+license=('GPL')
+groups=()
+makedepends=('git')
+source=("git+https://github.com/quiettheme/gtk")
+md5sums=('SKIP')
+
+pkgver() {
+ cd gtk
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/themes/Quiet"
+ cp -a "${srcdir}/gtk/Quiet/"* "${pkgdir}/usr/share/themes/Quiet/"
+}