summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJishnu Mohan2018-02-26 18:41:56 +0530
committerJishnu Mohan2018-02-26 18:41:56 +0530
commitd4e50bf789e84f1b0db245f6fd5331c6b1056b4f (patch)
tree7ef9d2ca10dc91f34e6f08696eb96e877b7be578
parent513cc2ae28c2b9e304dca836b889c3e3c0bf6a1d (diff)
downloadaur-d4e50bf789e84f1b0db245f6fd5331c6b1056b4f.tar.gz
update to v1.5.2
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD7
-rw-r--r--meson.build.patch9
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6450e0b9eaea..cbd8e5942767 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = quilter
pkgdesc = Focus on your writing for any kind of story, even longer ones.
- pkgver = 1.3.5
+ pkgver = 1.5.2
pkgrel = 1
url = https://github.com/lainsce/quilter
install = quilter.install
@@ -16,8 +16,8 @@ pkgbase = quilter
depends = discount
depends = webkit2gtk
depends = gtkspell3
- source = https://github.com/lainsce/quilter/archive/1.3.5.zip
- sha256sums = dc7d95566250ed0d533744162717884eff7c185086f213308220c3463a41bb1b
+ source = https://github.com/lainsce/quilter/archive/1.5.2.zip
+ sha256sums = ec5e6738f3db6ccb1f051292526787b60db07ce5cdd27778cc27a94ce40c6a5b
pkgname = quilter
diff --git a/PKGBUILD b/PKGBUILD
index ef5af58cd7c6..f86ef199a287 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Jishnu Mohan jishnu7 at gmail dot com
pkgname=quilter
-pkgver=1.3.5
+pkgver=1.5.2
pkgrel=1
pkgdesc="Focus on your writing for any kind of story, even longer ones."
arch=(any)
@@ -13,12 +13,13 @@ install=quilter.install
source=(
"https://github.com/lainsce/quilter/archive/${pkgver}.zip"
)
-sha256sums=('dc7d95566250ed0d533744162717884eff7c185086f213308220c3463a41bb1b')
+sha256sums=('ec5e6738f3db6ccb1f051292526787b60db07ce5cdd27778cc27a94ce40c6a5b')
build () {
cd $srcdir/$pkgname-$pkgver
+ patch meson.build -i ../../meson.build.patch
meson build && cd build
- mesonconf -Dprefix=${pkgdir}/usr
+ meson configure -Dprefix=${pkgdir}/usr
}
package() {
diff --git a/meson.build.patch b/meson.build.patch
new file mode 100644
index 000000000000..66cc510a0b60
--- /dev/null
+++ b/meson.build.patch
@@ -0,0 +1,9 @@
+43,47c43,44
+< libmarkdown = dependency('libmarkdown', version: '>= 2.2.1', required: false)
+< if libmarkdown.found() == false
+< cc = meson.get_compiler('c')
+< libmarkdown = cc.find_library('libmarkdown', required: true)
+< endif
+---
+> cc = meson.get_compiler('c')
+> libmarkdown = cc.find_library('libmarkdown', required: true)