summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhndrkk2023-01-09 23:20:18 +0100
committerhndrkk2023-01-09 23:20:18 +0100
commitce636c2141228944d2c640d51a1938bbfcf60892 (patch)
tree357a32aabf74d76392874dfd0e38557c4dc5c986
parent6f5a475abe86f593bd83fc8cfd07ef11bea2b0b7 (diff)
downloadaur-ce636c2141228944d2c640d51a1938bbfcf60892.tar.gz
cleanup by ra1nb0w
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD70
-rw-r--r--icon.pngbin0 -> 297209 bytes
-rw-r--r--quisk2
-rw-r--r--quisk.desktop19
5 files changed, 54 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f2f824294b0..8304103b1f66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,29 @@
pkgbase = quisk
- pkgdesc = Software defined radio (SDR)
- pkgver = 4.2.9
+ pkgdesc = QUISK is a Software Defined Radio (SDR) transceiver that can control various radio hardware.
+ pkgver = 4.2.14
pkgrel = 1
url = http://james.ahlstrom.name/quisk/
- arch = i686
arch = x86_64
- license = GPL
+ arch = aarch64
+ license = GPL2
+ makedepends = python-pip
+ makedepends = python-setuptools
depends = python
- depends = fftw
- depends = portaudio
+ depends = python-pyusb
depends = python-wxpython
- optdepends = codec2: Enable digital voice communication with FreeDV
- source = https://files.pythonhosted.org/packages/de/3d/9500e98d1a250189b29023e08209879947fd920f4176e8ece480e705f956/quisk-4.2.9.tar.gz
- source = quisk
+ depends = portaudio
+ depends = alsa-lib
+ depends = libpulse
+ depends = fftw
+ depends = python-pyserial
+ optdepends = codec2: Enable FreeDV open digital voice codec
+ optdepends = wdsp: Use high performance DSP library
+ optdepends = soapysdr: Enable SoapySDR support
+ source = quisk-4.2.14.tar.gz::https://pypi.io/packages/source/q/quisk/quisk-4.2.14.tar.gz
+ source = icon.png
source = quisk.desktop
- sha512sums = 99ceef2e9c09a893d9e9f905665df4c9da48a8bbd91b7c394111d62a4a406c85e1eead092d0e8e4268d5c0f5d6c82c923087f67d4c36e920ef3f015d160fccd8
- sha512sums = 58b0146411411301ffcbf3f71081b2a421d0c0e0d3e33c16d2e8d0d9786b249999609c0f4f4d5ed68c217d343a88230af49947d99621def8ec45ec0861135a07
- sha512sums = 3ad02f730b4a4033b86a2ce510865c13c2f2e228304283cae0bb389442f7ab49a5d530cd94e32460e19b53da24037abc855027ce34c93fdabcd1faf8a91852b1
+ sha256sums = 03fba8bed9b6fe21528da6533b49d4f7ac83e902f71bace2ae3511144b9baa83
+ sha256sums = a20dd6847c4554d79606cc86a1514671cbc2ef9d472d43e9c1b9d8d09665fbc8
+ sha256sums = 634f37687447651cd09d82583ce4a0ef5d39968f92b04671e3fbe6bbadf466a9
pkgname = quisk
diff --git a/PKGBUILD b/PKGBUILD
index 389db73a2433..460bd64af296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,38 @@
# Maintainer: ramen <hendrik@hndrkk.sh>
+# Contributor: ra1nb0w
# Contributor: Andreas Schreiner <andreas.schreiner@sonnenmulde.at>
# Contributor: Mike WB2FKO <mph at sportscliche dot com>
+
pkgname=quisk
-pkgver=4.2.9
+pkgver=4.2.14
pkgrel=1
-pkgdesc="Software defined radio (SDR)"
-arch=('i686' 'x86_64')
-url="http://james.ahlstrom.name/quisk/"
-license=('GPL')
-depends=('python' 'fftw' 'portaudio' 'python-wxpython')
-optdepends=('codec2: Enable digital voice communication with FreeDV')
-source=(https://files.pythonhosted.org/packages/de/3d/9500e98d1a250189b29023e08209879947fd920f4176e8ece480e705f956/$pkgname-$pkgver.tar.gz
- quisk
- quisk.desktop)
-sha512sums=('99ceef2e9c09a893d9e9f905665df4c9da48a8bbd91b7c394111d62a4a406c85e1eead092d0e8e4268d5c0f5d6c82c923087f67d4c36e920ef3f015d160fccd8'
- '58b0146411411301ffcbf3f71081b2a421d0c0e0d3e33c16d2e8d0d9786b249999609c0f4f4d5ed68c217d343a88230af49947d99621def8ec45ec0861135a07'
- '3ad02f730b4a4033b86a2ce510865c13c2f2e228304283cae0bb389442f7ab49a5d530cd94e32460e19b53da24037abc855027ce34c93fdabcd1faf8a91852b1')
+pkgdesc='QUISK is a Software Defined Radio (SDR) transceiver that can control various radio hardware.'
+arch=('x86_64' 'aarch64')
+url='http://james.ahlstrom.name/quisk/'
+license=('GPL2')
+depends=('python' 'python-pyusb' 'python-wxpython')
+depends+=('portaudio' 'alsa-lib' 'libpulse' 'fftw' 'python-pyserial')
+optdepends=('codec2: Enable FreeDV open digital voice codec'
+ 'wdsp: Use high performance DSP library'
+ 'soapysdr: Enable SoapySDR support')
+makedepends=('python-pip' 'python-setuptools')
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://pypi.io/packages/source/q/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'icon.png'
+ 'quisk.desktop'
+)
+sha256sums=('03fba8bed9b6fe21528da6533b49d4f7ac83e902f71bace2ae3511144b9baa83'
+ 'a20dd6847c4554d79606cc86a1514671cbc2ef9d472d43e9c1b9d8d09665fbc8'
+ '634f37687447651cd09d82583ce4a0ef5d39968f92b04671e3fbe6bbadf466a9')
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py build_ext --force --inplace
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
}
package() {
- mkdir -p $pkgdir/opt/$pkgname
- cd "$srcdir/$pkgname-$pkgver"
- install -Dm644 quisk $pkgdir/opt/$pkgname/quisk
- cp -ra *.h $pkgdir/opt/$pkgname
- cp -ra *.c $pkgdir/opt/$pkgname
- cp -ra *.html $pkgdir/opt/$pkgname
- cp -ra *.py $pkgdir/opt/$pkgname
- cp -ra *.so $pkgdir/opt/$pkgname
- cp -ra *.txt $pkgdir/opt/$pkgname
-# mv charleston "$pkgdir/opt/$pkgname"
- mv n2adr "$pkgdir/opt/$pkgname"
- mv sdriqpkg "$pkgdir/opt/$pkgname"
- mv softrock "$pkgdir/opt/$pkgname"
-# mv usb "$pkgdir/opt/$pkgname"
- mv hiqsdr "$pkgdir/opt/$pkgname"
- mv hermes "$pkgdir/opt/$pkgname"
- find "$pkgdir/opt/$pkgname/" -type f | xargs chmod 644
- find "$pkgdir/opt/$pkgname/" -type d | xargs chmod 755
- cd $srcdir
- mkdir -p $pkgdir/usr/share/applications
-# If the working directory is moved (e.g. from /opt to /home)
-# the following .desktop file will have to be edited. Developer
-# has not provided a launcher icon.
- install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
- echo -e "\n Quisk will be installed in the /opt directory of root \n"
- mkdir -p $pkgdir/usr/bin
- install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root "${pkgdir}" --optimize=1 --skip-build
+ install -D "${srcdir}/icon.png" -m 0644 "${pkgdir}/usr/share/${pkgname}/${pkgname}_icon.png"
+ install -D "${srcdir}/quisk.desktop" -m 0644 "${pkgdir}/usr/share/applications/quisk.desktop"
}
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..3dce28fc4a48
--- /dev/null
+++ b/icon.png
Binary files differ
diff --git a/quisk b/quisk
deleted file mode 100644
index 278cfb136189..000000000000
--- a/quisk
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-python /opt/quisk/quisk.py
diff --git a/quisk.desktop b/quisk.desktop
index c590dbe93e38..4218c230c363 100644
--- a/quisk.desktop
+++ b/quisk.desktop
@@ -1,16 +1,9 @@
[Desktop Entry]
-Name=quisk
-Name[en_US]=quisk
-Comment=Software defined radio
-Comment[en_US]=Software defined radio
-Encoding=UTF-8
-Exec=python2 /opt/quisk/quisk.py
-Icon=
-MimeType=text
-StartupNotify=true
+Name=Quisk
+GenericName=Software Defined Radio (SDR) transceiver
+Comment=Software Defined Radio (SDR) transceiver
+Exec=quisk
+Icon=/usr/share/quisk/quisk_icon.png
Terminal=false
-TerminalOptions=
Type=Application
-Categories=Application;HamRadio
-X-DCOP-ServiceType=none
-X-KDE-SubstituteUID=false
+Categories=Network;HamRadio;