summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValters2021-01-09 19:24:30 +0200
committerValters2021-01-09 19:24:30 +0200
commit0c51b101ad9142b5b5b0cfd9cc2f3d56e97e561e (patch)
tree2e7b41198af39d34caf6c36514b443db4f10a9fd
downloadaur-0c51b101ad9142b5b5b0cfd9cc2f3d56e97e561e.tar.gz
Add quixel-bridge pkgbuild
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7112b22e66a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = quixel-bridge
+ pkgdesc = A tool for browsing, searching, downloading, importing and exporting Megascans assets
+ pkgver = 2020.4.2
+ pkgrel = 1
+ url = https://quixel.com/bridge
+ arch = x86_64
+ license = custom:Commercial
+ depends = zlib
+ depends = hicolor-icon-theme
+ noextract = Bridge.AppImage
+ options = !strip
+ source_x86_64 = https://d2shgxa8i058x8.cloudfront.net/bridge/linux/Bridge.AppImage
+ sha256sums_x86_64 = 136ee02b6c51a187fb98f4af0bffd04561790be99865dd8a8e49ec119f483e40
+
+pkgname = quixel-bridge
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbd6ed3b3b43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Valters Tomsons <valters.tomsons at protonmail dot com>
+
+_appimage="Bridge.AppImage"
+_desktop="megascans-bridge.desktop"
+
+pkgname="quixel-bridge"
+pkgver=2020.4.2
+pkgrel=1
+pkgdesc="A tool for browsing, searching, downloading, importing and exporting Megascans assets"
+arch=('x86_64')
+url="https://quixel.com/bridge"
+license=('custom:Commercial')
+depends=('zlib' 'hicolor-icon-theme')
+options=(!strip)
+source_x86_64=("https://d2shgxa8i058x8.cloudfront.net/bridge/linux/${_appimage}")
+noextract=("${_appimage}")
+sha256sums_x86_64=('136ee02b6c51a187fb98f4af0bffd04561790be99865dd8a8e49ec119f483e40')
+
+prepare() {
+ chmod +x "${_appimage}"
+ ./"${_appimage}" --appimage-extract
+}
+
+build() {
+ # Adjust .desktop so it will work outside of AppImage container
+ sed -i -E "s|Exec=AppRun|Exec=env DESKTOPINTEGRATION=false /usr/bin/${pkgname}|"\
+ "squashfs-root/${_desktop}"
+
+ # Fix permissions; .AppImage permissions are 700 for all directories
+ chmod -R a-x+rX squashfs-root/usr
+}
+
+package() {
+ # AppImage
+ install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${pkgname}/${_appimage}"
+
+ # Desktop file
+ install -Dm644 "${srcdir}/squashfs-root/${_desktop}" "${pkgdir}/usr/share/applications/${_desktop}"
+
+ # Icon Iimages
+ install -dm755 "${pkgdir}/usr/share/"
+ cp -a "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
+
+ # Symlink
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/${_appimage}" "${pkgdir}/usr/bin/${pkgname}"
+} \ No newline at end of file