summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdmiringWorm2019-04-13 20:47:28 +0200
committerAdmiringWorm2019-04-13 20:47:28 +0200
commitab22dd660228921352320ef06bf6f9a23ccbf87c (patch)
treed13b2224b565b21e8e293ea1cb7384d83542648d
downloadaur-ab22dd660228921352320ef06bf6f9a23ccbf87c.tar.gz
Initial build script implementation
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c338c1c1e67c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = qutepart
+ pkgdesc = Code editor component for PyQt and Pyside
+ pkgver = 3.2.0
+ pkgrel = 1
+ url = https://github.com/hlamer/qutepart
+ arch = x86_64
+ license = LGPL
+ makedepends = python-setuptools
+ depends = python-pyqt5
+ source = qutepart-3.2.0.tar.gz::https://github.com/hlamer/qutepart/archive/v3.2.0.tar.gz
+ sha256sums = 1e58699b3306077b9faa18baa30cff3edc63eb2058c33f11f4b5aed8bbf3e599
+
+pkgname = qutepart
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..79042f2232df
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+*.log
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ce8928c0467
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: AdmiringWorm <kim.nordmo@gmail.com>
+pkgname=qutepart
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="Code editor component for PyQt and Pyside"
+arch=('x86_64')
+url="https://github.com/hlamer/qutepart"
+license=('LGPL')
+depends=("python-pyqt5")
+makedepends=("python-setuptools")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/hlamer/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('1e58699b3306077b9faa18baa30cff3edc63eb2058c33f11f4b5aed8bbf3e599')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ python tests/run_all.py
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}