summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfei.chong2023-07-10 17:17:02 +0800
committerfei.chong2023-07-10 17:17:02 +0800
commit31d1a9718a3d45b72742d887edb9e519f100b055 (patch)
tree05f5ae559f8652e556a8858bd1ae8a6beae90b08
parent3f9e12164d2ab1a53ce6e01b48aa84e6959d929b (diff)
downloadaur-31d1a9718a3d45b72742d887edb9e519f100b055.tar.gz
fix: submodule error and build error
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23d95bcc3ee1..24241b3cf671 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qv2ray-git
pkgdesc = A cross platform connection manager for V2Ray and other backends
- pkgver = 3.0.0.rc1.r24.g2aec20c6
+ pkgver = 3.0.0.rc1.r57.g8213f99d
pkgrel = 1
url = https://github.com/Shadowsocks-NET/Qv2ray
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index fdf2555c4a85..a988acc9d708 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sam L. Yes <samlukeyes123 at gmail dot com>
pkgname=qv2ray-git
-pkgver=3.0.0.rc1.r24.g2aec20c6
+pkgver=3.0.0.rc1.r57.g8213f99d
pkgrel=1
pkgdesc="A cross platform connection manager for V2Ray and other backends"
arch=(x86_64)
@@ -44,7 +44,7 @@ patch_gitmodules() {
prepare() {
cd "$srcdir/$pkgname"
patch_gitmodules
- git submodule update --init \
+ git -c protocol.file.allow=always submodule update --init \
3rdparty/SingleApplication \
3rdparty/QCodeEditor \
3rdparty/qt-qrcode \
@@ -57,6 +57,7 @@ prepare() {
build() {
cd "$srcdir/$pkgname"
+ sed 's/{}/TagEntryWidget::QPrivateSignal{}/' -i src/ui/widgets/TagLineEditorWidget.cpp
mkdir -p build && cd build
cmake .. \
-DBUILD_TESTING=OFF \