summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDct Mei2020-08-08 13:56:59 +0800
committerDct Mei2020-08-08 13:56:59 +0800
commit6f015b3ce8bffe9cd17ed55cec15b11f1023c706 (patch)
tree82b43e6fe4f02d727c209b3a3b10ad93bf749f2d
parent0bf02d0ccf0e1a3bc52bf5d82ffacb2291668da1 (diff)
downloadaur-6f015b3ce8bffe9cd17ed55cec15b11f1023c706.tar.gz
feat: v2.0.0-2
1. Adjust dependencies. 2. Correct the permission of libQvCommandPlugin.so to 755.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be87a1dd2cc1..f15c7d4ac9f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qv2ray-plugin-command
pkgdesc = Qv2ray Plugin: Command
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Qv2ray/QvPlugin-Command
arch = x86_64
groups = qv2ray-plugin
@@ -9,6 +9,7 @@ pkgbase = qv2ray-plugin-command
makedepends = cmake
makedepends = git
makedepends = ninja
+ depends = qt5-base
depends = qv2ray
source = qv2ray-plugin-command-2.0.0::git+https://github.com/Qv2ray/QvPlugin-Command.git#tag=v2.0.0
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a3bfaa3827bb..d36471daa245 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=qv2ray-plugin-command
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Qv2ray Plugin: Command"
arch=('x86_64')
url="https://github.com/Qv2ray/QvPlugin-Command"
license=('GPL3')
-depends=('qv2ray')
+depends=('qt5-base' 'qv2ray')
makedepends=('cmake' 'git' 'ninja')
groups=('qv2ray-plugin')
source=("$pkgname-$pkgver::git+$url.git#tag=v$pkgver")
@@ -29,5 +29,5 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver/build/"
- install -Dm 644 libQvCommandPlugin.so -t "$pkgdir/usr/share/qv2ray/plugins/"
+ install -Dm 755 libQvCommandPlugin.so -t "$pkgdir/usr/share/qv2ray/plugins/"
}