summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuckSoft2020-11-15 19:42:28 +0800
committerDuckSoft2020-11-15 19:42:28 +0800
commit11af747695f3680e90c1f174cf4b7b8fd2c25f1e (patch)
treec956d2b9868c01caa80fdab4f23ca32bf3ecd345
parent2034327b8779524a314930455d4775745113fd0b (diff)
downloadaur-11af747695f3680e90c1f174cf4b7b8fd2c25f1e.tar.gz
fix install path
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56ce454ef610..2860742d90e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: DuckSoft <realducksoft at gmail dot com>
pkgname=qv2ray-plugin-trojan-go-git
_pkgname=qv2ray-plugin-trojan-go
-pkgver=20200715.r18.a86ffd6
+pkgver=20200929.r27.f83b72d
pkgrel=1
pkgdesc="Qv2ray Plugin: Trojan-Go (Stable Build)"
arch=('x86_64')
@@ -30,15 +30,16 @@ build() {
cd "$srcdir"/"$_pkgname"
mkdir -p build && cd build
cmake .. \
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}"/usr \
-DCMAKE_BUILD_TYPE=Release \
-GNinja
- ninja
+ cmake --build .
}
package() {
# NOTE: Working around extra-x86_64-build
depends+=('qv2ray' 'trojan-go')
cd "$srcdir"/"$_pkgname"/build
- install -Dm644 libQvTrojanGoPlugin.so "$pkgdir"/usr/share/qv2ray/plugins/libQvGoTrojanPlugin.so
+ cmake --install .
# NOTE: This virtual dependency will be introduced after Qv2ray stablize its interface.
# depends+=(${_virtualdepends[@]})
}