summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamLukeYes2022-01-13 18:10:04 +0800
committerSamLukeYes2022-01-13 18:10:04 +0800
commit623a0dfc0ea964cf5c3cce4a2e223944747de6f8 (patch)
tree9839af28219a7c5a8d58e3c15cef365a82f53abc
parentd9b00330249bd35f178685d0437f9342e7533908 (diff)
downloadaur-623a0dfc0ea964cf5c3cce4a2e223944747de6f8.tar.gz
add submodules to sources
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 62 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c8cb86904a7..88e8ade32b84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qv2ray-v3
pkgdesc = A cross platform connection manager for V2Ray and other backends.
pkgver = 3.0.0rc1
- pkgrel = 1
+ pkgrel = 4
url = https://github.com/Shadowsocks-NET/Qv2ray
arch = x86_64
license = GPL3
@@ -18,10 +18,30 @@ pkgbase = qv2ray-v3
depends = hicolor-icon-theme
depends = qt6-svg
optdepends = qt6-wayland: Wayland support (experimental)
- optdepends = v2ray: use packaged v2ray
+ optdepends = v2ray: Default V2Ray core
provides = qv2ray
conflicts = qv2ray
source = qv2ray-v3::git+https://github.com/Shadowsocks-NET/Qv2ray.git#tag=v3.0.0-rc1
+ source = git+https://github.com/itay-grudev/SingleApplication.git
+ source = git+https://github.com/cpeditor/QCodeEditor.git
+ source = git+https://github.com/danielsanfr/qt-qrcode.git
+ source = git+https://github.com/Shadowsocks-NET/Qv2rayBase.git
+ source = git+https://github.com/xiaokangwang/v2ray-core-1.git
+ source = git+https://github.com/moodyhunter/libRoutingA.git
+ source = git+https://github.com/fukuchi/libqrencode.git
+ source = git+https://github.com/libuv/libuv.git
+ source = git+https://github.com/skypjack/uvw.git
+ source = git+https://github.com/Shadowsocks-NET/Qv2rayBase-PluginInterface.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = qv2ray-v3
diff --git a/.gitignore b/.gitignore
index 5cfcc6b7f776..0ef9fd001eea 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,3 @@
-qv2ray-v3/
-src/
-pkg/
+*/
*.tar*
*.log \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 21e4d1a9bdfc..2bd535b572af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,56 @@
pkgname=qv2ray-v3
_tag=v3.0.0-rc1
pkgver=3.0.0rc1
-pkgrel=1
+pkgrel=4
pkgdesc="A cross platform connection manager for V2Ray and other backends."
arch=(x86_64)
url="https://github.com/Shadowsocks-NET/Qv2ray"
license=('GPL3')
depends=('grpc' 'hicolor-icon-theme' 'qt6-svg')
makedepends=('cmake' 'gcc' 'git' 'grpc-cli' 'make' 'ninja' 'qt6-declarative' 'qt6-tools' 'which')
-optdepends=('qt6-wayland: Wayland support (experimental)' 'v2ray: use packaged v2ray')
+optdepends=(
+ 'qt6-wayland: Wayland support (experimental)'
+ 'v2ray: Default V2Ray core'
+)
provides=('qv2ray')
conflicts=('qv2ray')
-source=("$pkgname::git+$url.git#tag=$_tag")
-sha512sums=('SKIP')
+source=(
+ "$pkgname::git+$url.git#tag=$_tag"
+ "git+https://github.com/itay-grudev/SingleApplication.git"
+ "git+https://github.com/cpeditor/QCodeEditor.git"
+ "git+https://github.com/danielsanfr/qt-qrcode.git"
+ "git+https://github.com/Shadowsocks-NET/Qv2rayBase.git"
+ "git+https://github.com/xiaokangwang/v2ray-core-1.git"
+ "git+https://github.com/moodyhunter/libRoutingA.git"
+ "git+https://github.com/fukuchi/libqrencode.git"
+ "git+https://github.com/libuv/libuv.git"
+ "git+https://github.com/skypjack/uvw.git"
+ "git+https://github.com/Shadowsocks-NET/Qv2rayBase-PluginInterface.git"
+)
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+patch_gitmodules() {
+ sed -i "s|https://github.com/.*/|${srcdir}/|;s|.git||" .gitmodules
+ git submodule update --init --force --remote
+}
prepare() {
cd "$srcdir/$pkgname"
- git submodule update --init --recursive
+ patch_gitmodules
+ cd "3rdparty/qt-qrcode"
+ patch_gitmodules
+ cd "../../src/Qv2rayBase"
+ patch_gitmodules
}
build() {