summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamLukeYes2021-10-05 20:45:41 +0800
committerSamLukeYes2021-10-05 20:45:41 +0800
commitd9b00330249bd35f178685d0437f9342e7533908 (patch)
tree23beeffacd9802ed61be2346abddb7c053d768bd
downloadaur-d9b00330249bd35f178685d0437f9342e7533908.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c8cb86904a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = qv2ray-v3
+ pkgdesc = A cross platform connection manager for V2Ray and other backends.
+ pkgver = 3.0.0rc1
+ pkgrel = 1
+ url = https://github.com/Shadowsocks-NET/Qv2ray
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = git
+ makedepends = grpc-cli
+ makedepends = make
+ makedepends = ninja
+ makedepends = qt6-declarative
+ makedepends = qt6-tools
+ makedepends = which
+ depends = grpc
+ depends = hicolor-icon-theme
+ depends = qt6-svg
+ optdepends = qt6-wayland: Wayland support (experimental)
+ optdepends = v2ray: use packaged v2ray
+ provides = qv2ray
+ conflicts = qv2ray
+ source = qv2ray-v3::git+https://github.com/Shadowsocks-NET/Qv2ray.git#tag=v3.0.0-rc1
+ sha512sums = SKIP
+
+pkgname = qv2ray-v3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5cfcc6b7f776
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+qv2ray-v3/
+src/
+pkg/
+*.tar*
+*.log \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21e4d1a9bdfc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Sam L. Yes <samlukeyes123 at gmail dot com>
+# Contributor: database64128 <free122448@hotmail.com>
+pkgname=qv2ray-v3
+_tag=v3.0.0-rc1
+pkgver=3.0.0rc1
+pkgrel=1
+pkgdesc="A cross platform connection manager for V2Ray and other backends."
+arch=(x86_64)
+url="https://github.com/Shadowsocks-NET/Qv2ray"
+license=('GPL3')
+depends=('grpc' 'hicolor-icon-theme' 'qt6-svg')
+makedepends=('cmake' 'gcc' 'git' 'grpc-cli' 'make' 'ninja' 'qt6-declarative' 'qt6-tools' 'which')
+optdepends=('qt6-wayland: Wayland support (experimental)' 'v2ray: use packaged v2ray')
+provides=('qv2ray')
+conflicts=('qv2ray')
+source=("$pkgname::git+$url.git#tag=$_tag")
+sha512sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ export _QV2RAY_BUILD_INFO_="$pkgname AUR package"
+ export _QV2RAY_BUILD_EXTRA_INFO_="r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ mkdir -p build && cd build
+ cmake .. -GNinja \
+ -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQV2RAY_DEFAULT_VASSETS_PATH="/usr/share/v2ray" \
+ -DQV2RAY_DEFAULT_VCORE_PATH="/usr/bin/v2ray" \
+ -DQV2RAY_DISABLE_AUTO_UPDATE=on
+ ninja
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ ninja -C "build" install
+}