summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-01-08 22:39:48 +0100
committerCarsten Teibes2014-01-08 22:39:48 +0100
commit373b20829d5ac7cd2ce259d33b41498727ef2f22 (patch)
tree85df6e9e0b09906dea166579cf96f475f9a6347c
parent8670462d4b495e30e7bf2a6f509eec8226ac8028 (diff)
downloadaur-373b20829d5ac7cd2ce259d33b41498727ef2f22.tar.gz
Cleanup
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63c276815458..640b47b55517 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,13 +2,12 @@ pkgbase = qwad
pkgdesc = A Python-Qt utility to manage Wad files with NUS downloader for Wii
pkgver = 0.9
pkgrel = 1
- url = http://www.nanolx.org/
+ url = http://www.nanolx.org
arch = any
license = GPL3
depends = python2-crypto
depends = python2-pyqt
- source = http://nanolx.org/downloads/Qwad/qwad_0.9.tar.bz2
- md5sums = 0481b2115bb02b838f5ad5324b2c9afb
+ source = http://www.nanolx.org/downloads/Qwad/qwad_0.9.tar.bz2
sha256sums = 10689ff8a457ec25726ed1500c5a2c8013661a8e9e56342d8d425155214cbc2b
pkgname = qwad
diff --git a/PKGBUILD b/PKGBUILD
index 474cc0649b7d..775de5ccdcbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,35 @@
-# Maintainer: carstene1ns <arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=qwad
pkgver=0.9
pkgrel=1
pkgdesc="A Python-Qt utility to manage Wad files with NUS downloader for Wii"
arch=('any')
-url="http://www.nanolx.org/"
+url="http://www.nanolx.org"
license=('GPL3')
depends=('python2-crypto' 'python2-pyqt')
-source=("http://nanolx.org/downloads/Qwad/${pkgname}_${pkgver}.tar.bz2")
-md5sums=('0481b2115bb02b838f5ad5324b2c9afb')
+source=("$url/downloads/Qwad/${pkgname}_$pkgver.tar.bz2")
sha256sums=('10689ff8a457ec25726ed1500c5a2c8013661a8e9e56342d8d425155214cbc2b')
prepare() {
- cd "$srcdir/${pkgname}_${pkgver}"
+ cd ${pkgname}_$pkgver
# QT 4 fix
sed -i -e "s|-lrelease|-lrelease-qt4|" Makefile
}
build() {
- cd "${srcdir}/${pkgname}_${pkgver}"
+ cd ${pkgname}_$pkgver
# build translation(s)
make
}
package() {
- cd "$srcdir/${pkgname}_${pkgver}"
+ cd ${pkgname}_$pkgver
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir/" make install
# python 2 fix
- sed -i -e "s|python|/usr/bin/env python2|" $pkgdir/usr/bin/$pkgname
+ sed -i -e "s|python|/usr/bin/env python2|" "$pkgdir"/usr/bin/$pkgname
}