summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2013-10-01 03:47:53 +0200
committerCarsten Teibes2013-10-01 03:47:53 +0200
commit8670462d4b495e30e7bf2a6f509eec8226ac8028 (patch)
treec0eef6bc9b3a1aef9492f95142ac76c241cf5e94
downloadaur-8670462d4b495e30e7bf2a6f509eec8226ac8028.tar.gz
[add] qwad 0.9
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63c276815458
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qwad
+ pkgdesc = A Python-Qt utility to manage Wad files with NUS downloader for Wii
+ pkgver = 0.9
+ pkgrel = 1
+ url = http://www.nanolx.org/
+ arch = any
+ license = GPL3
+ depends = python2-crypto
+ depends = python2-pyqt
+ source = http://nanolx.org/downloads/Qwad/qwad_0.9.tar.bz2
+ md5sums = 0481b2115bb02b838f5ad5324b2c9afb
+ sha256sums = 10689ff8a457ec25726ed1500c5a2c8013661a8e9e56342d8d425155214cbc2b
+
+pkgname = qwad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..474cc0649b7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: carstene1ns <arch carsten-teibes de>
+
+pkgname=qwad
+pkgver=0.9
+pkgrel=1
+pkgdesc="A Python-Qt utility to manage Wad files with NUS downloader for Wii"
+arch=('any')
+url="http://www.nanolx.org/"
+license=('GPL3')
+depends=('python2-crypto' 'python2-pyqt')
+source=("http://nanolx.org/downloads/Qwad/${pkgname}_${pkgver}.tar.bz2")
+md5sums=('0481b2115bb02b838f5ad5324b2c9afb')
+sha256sums=('10689ff8a457ec25726ed1500c5a2c8013661a8e9e56342d8d425155214cbc2b')
+
+prepare() {
+ cd "$srcdir/${pkgname}_${pkgver}"
+
+ # QT 4 fix
+ sed -i -e "s|-lrelease|-lrelease-qt4|" Makefile
+}
+
+build() {
+ cd "${srcdir}/${pkgname}_${pkgver}"
+
+ # build translation(s)
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}_${pkgver}"
+
+ DESTDIR="$pkgdir" make install
+
+ # python 2 fix
+ sed -i -e "s|python|/usr/bin/env python2|" $pkgdir/usr/bin/$pkgname
+}