summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira2015-06-14 02:19:10 -0300
committerVinícius dos Santos Oliveira2015-06-14 02:19:10 -0300
commit0785fa00d4348e4489b0164f078f44e3b51e6f68 (patch)
tree83c44f3b5f57e534da4bb414edbc2972ace8aaab
downloadaur-0785fa00d4348e4489b0164f078f44e3b51e6f68.tar.gz
Genesis commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD49
-rw-r--r--qwbfs.install9
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03d079b7bf79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = qwbfs
+ pkgdesc = Cross platform WBFS file system manager
+ pkgver = 1.2.5
+ pkgrel = 2
+ url = https://github.com/pasnox/qwbfsmanager
+ install = qwbfs.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ source = qwbfs::git+https://github.com/pasnox/qwbfsmanager.git#tag=v1.2.5
+ source = fresh::git+https://github.com/pasnox/fresh.git#commit=cd735c55c54ca8917704d231022e1ed46c3b42a8
+ source = qmake-extensions::git+https://github.com/pasnox/qmake-extensions.git#commit=b60b99bccbfda40136c8aa1a54770543519feda8
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = qwbfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe08f7b59437
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+pkgname=qwbfs
+pkgver=1.2.5
+pkgrel=2
+pkgdesc="Cross platform WBFS file system manager"
+arch=('i686' 'x86_64')
+url="https://github.com/pasnox/qwbfsmanager"
+license=('GPL2')
+# Also 'openssl', but already satisfied:
+depends=('qt5-base' 'hicolor-icon-theme')
+makedepends=('git')
+install=${pkgname}.install
+source=("qwbfs::git+https://github.com/pasnox/qwbfsmanager.git#tag=v1.2.5"
+ "fresh::git+https://github.com/pasnox/fresh.git#commit=cd735c55c54ca8917704d231022e1ed46c3b42a8"
+ "qmake-extensions::git+https://github.com/pasnox/qmake-extensions.git#commit=b60b99bccbfda40136c8aa1a54770543519feda8")
+sha1sums=('SKIP' 'SKIP' 'SKIP')
+
+prepare() {
+ cd "$srcdir/qwbfs"
+ git submodule init
+ git config submodule.fresh.git.url "$srcdir/fresh"
+ git submodule update
+
+ cd "fresh.git"
+ git submodule init
+ git config submodule.qmake-extensions.git.url "$srcdir/qmake-extensions"
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/qwbfs"
+
+ qmake PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/qwbfs"
+
+ mkdir -p "$pkgdir/usr/bin"
+ cp bin/qwbfsmanager "$pkgdir/usr/bin"
+
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp packages/QWBFSManager.desktop "$pkgdir/usr/share/applications"
+
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/512x512/apps"
+ cp qwbfs/resources/qwbfsmanager.png \
+ "$pkgdir/usr/share/icons/hicolor/512x512/apps"
+}
diff --git a/qwbfs.install b/qwbfs.install
new file mode 100644
index 000000000000..aa01b09e9149
--- /dev/null
+++ b/qwbfs.install
@@ -0,0 +1,9 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: