summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim De Clercq2022-06-25 19:08:01 +0200
committerMaxim De Clercq2022-06-25 19:08:01 +0200
commit9c994eb2e4e5bbe6cd82b5359048fa81e233e842 (patch)
tree41e3b462b61588bddbbb476570bf9c6acd33d1fe
downloadaur-9c994eb2e4e5bbe6cd82b5359048fa81e233e842.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40f08e4cb63c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qwbfsmanager-git
+ pkgdesc = QWBFS Manager provides a cross platform Qt 4 GUI for working with hard disk drives that have been formatted to the WBFS file system.
+ pkgver = 1.2.6.r4.g68bfd4887a
+ pkgrel = 1
+ url = https://github.com/pasnox/qwbfsmanager
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ makedepends = fresh
+ depends = qt4
+ provides = qwbfsmanager=1.2.6.r4.g68bfd4887a
+ conflicts = qwbfsmanager
+ source = qwbfsmanager-git::git+https://github.com/pasnox/qwbfsmanager.git
+ md5sums = SKIP
+
+pkgname = qwbfsmanager-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa796fc8b257
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Maxim De Clercq <maximdeclercq00@gmail.com>
+pkgname=qwbfsmanager-git
+pkgver=1.2.6.r4.g68bfd4887a
+pkgrel=1
+pkgdesc='QWBFS Manager provides a cross platform Qt 4 GUI for working with hard disk drives that have been formatted to the WBFS file system.'
+arch=('i686' 'x86_64')
+url='https://github.com/pasnox/qwbfsmanager'
+license=('LGPL3')
+depends=('qt4')
+makedepends=('git' 'fresh')
+provides=("qwbfsmanager=$pkgver")
+conflicts=('qwbfsmanager')
+source=("$pkgname::git+$url.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ git submodule update --init --recursive
+}
+
+pkgver() {
+ cd "$pkgname"
+ git describe --abbrev=10 --long --tags --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ qmake-qt4 PREFIX="/usr/" "qwbfs.pro"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make INSTALL_ROOT="$pkgdir/" install
+}