summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBronson2020-07-06 12:49:17 +0930
committerBronson2020-07-06 12:49:17 +0930
commitacfa327703d15f8a6463e1143016eb1bf4f09e39 (patch)
tree1178454ffb7fcbd754db70d48c8b45c2228142eb
downloadaur-acfa327703d15f8a6463e1143016eb1bf4f09e39.tar.gz
first version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8e33068cdd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qweather-git
+ pkgdesc = A simple weather application. Using BOM Australia weather provider. Written in QT/QML and C++.
+ pkgver = r76.e81d73d
+ pkgrel = 1
+ url = https://github.com/bit-shift-io/qweather
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-tools
+ makedepends = qt5-graphicaleffects
+ depends = qt5-base
+ provides = qweather
+ source = qweather-git::git+https://github.com/bit-shift-io/qweather.git
+ md5sums = SKIP
+
+pkgname = qweather-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d05c5abbd45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: bronson mathews <bronsonmathews@gmail.com> -> http://bitshift.io -> https://github.com/bit-shift-io
+pkgname=qweather-git
+pkgver=r76.e81d73d
+pkgrel=1
+pkgdesc="A simple weather application. Using BOM Australia weather provider. Written in QT/QML and C++."
+arch=('any')
+url="https://github.com/bit-shift-io/qweather"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('git' 'qt5-tools' 'qt5-graphicaleffects')
+provides=('qweather')
+source=("${pkgname}::git+https://github.com/bit-shift-io/qweather.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname}"
+ mkdir -p build
+ cd "${srcdir}/${pkgname}/build"
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/build"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" ../README.md
+}