summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHcra2019-02-18 10:26:37 +0100
committerHcra2019-02-18 10:26:37 +0100
commit00f6d4e9c3970b6c2965e607b39fb79ca3eb6818 (patch)
tree8745c3737696d75507483ded891fd32f4535c2bf
parentce0bf89e39947bf1e25740f9527397207c9fd1f7 (diff)
downloadaur-00f6d4e9c3970b6c2965e607b39fb79ca3eb6818.tar.gz
path trouble solved
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c641c4db4bd..673925d9fc85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qweborf-git
pkgdesc = Minimal HTTP server to share your files - Qt frontend
pkgver = 0.15
- pkgrel = 4
+ pkgrel = 6
url = https://ltworf.github.io/weborf/
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 5cf978af2aaf..aac342530b4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=qweborf-git
_pkgname="weborf"
pkgver=0.15
-pkgrel=4
+pkgrel=6
pkgdesc="Minimal HTTP server to share your files - Qt frontend"
arch=(any)
url='https://ltworf.github.io/weborf/'
@@ -19,15 +19,17 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+
build() {
cd "$srcdir/$_pkgname"
- pyuic5 qweborf/main.ui > qweborf/main.py
- python qweborf.setup.py build
+ #autoreconf -f -i
+ pyuic5 qweborf/qweborf/main.ui > qweborf/main.py
+ python qweborf/setup.py build
}
package() {
cd "$srcdir/$_pkgname"
- python qweborf.setup.py install --root="$pkgdir"
- install -Dm 0755 qweborf/qweborf "$pkgdir/usr/bin/qweborf"
- install -Dm 0755 qweborf/qweborf.desktop "$pkgdir/usr/share/applications/qweborf.desktop"
+ python build/lib/qweborf/setup.py install --root="$pkgdir"
+ install -Dm 0755 qwebrof/qweborf/qweborf "$pkgdir/usr/bin/qweborf"
+ #install -Dm 0755 qwebrof/qweborf/qweborf.desktop "$pkgdir/usr/share/applications/qweborf.desktop"
}