summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDušan Simić2021-12-11 18:33:26 +0100
committerDušan Simić2021-12-11 18:33:26 +0100
commitfeaacfb4b608d9e85b769b6093d27a800952a988 (patch)
treeab2aa2e7f0162db8ede08d18dc7ac46cae0cea7f
downloadaur-feaacfb4b608d9e85b769b6093d27a800952a988.tar.gz
Add all files
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09cbc48b40b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qwertone
+ pkgdesc = Simple music synthesizer app based on usual qwerty-keyboard for input
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://gitlab.com/azymohliad/qwertone
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = rust
+ depends = gtk3
+ depends = alsa-lib
+ source = git+https://gitlab.com/azymohliad/qwertone.git#commit=24bcfb08f332eb1b88b599194a20665b25650091
+ md5sums = SKIP
+
+pkgname = qwertone
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ad5943c1a56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dušan Simić <dusan.simic1810@gmail.com>
+
+pkgname=qwertone
+pkgver=0.4.0
+_commit=24bcfb08f332eb1b88b599194a20665b25650091
+pkgrel=1
+pkgdesc='Simple music synthesizer app based on usual qwerty-keyboard for input'
+arch=(x86_64)
+url=https://gitlab.com/azymohliad/qwertone
+license=(GPL3)
+depends=(gtk3 alsa-lib)
+makedepends=(git rust)
+source=("git+$url.git#commit=$_commit")
+md5sums=(SKIP)
+
+build() {
+ cd "$pkgname"
+ cargo build --release --locked
+}
+
+_appid="com.gitlab.azymohliad.Qwertone"
+
+package() {
+ cd "$pkgname"
+ install -Dm755 target/release/qwertone -t "$pkgdir/usr/bin"
+ install -Dm644 "res/$_appid.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "res/$_appid.appdata.xml" -t "$pkgdir/usr/share/metainfo"
+ install -Dm644 "res/icons/$_appid.svg" -t "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+ install -Dm644 "res/icons/$_appid-symbolic.svg" -t "$pkgdir/usr/share/icons/hicolor/symbolic/apps"
+}