summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-02-29 16:31:21 +0530
committerlibrewish2020-02-29 16:31:21 +0530
commitbb5fa2833615aaeb0ad3260bec8e63a172a73676 (patch)
tree2ae3eb664355b23f62c12639c83c7ae951256917
downloadaur-bb5fa2833615aaeb0ad3260bec8e63a172a73676.tar.gz
initial
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD49
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95e1c02e14d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = qwikaccess-git
+ pkgdesc = A point and click Qt GUI for scripts we use frequently.
+ pkgver = 2.8.0.r1.a796070
+ pkgrel = 1
+ url = https://github.com/librewish/qwikaccess
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ depends = polkit
+ optdepends = ffmpeg: for screenshot & audio,screen,screencam recording
+ optdepends = v4l-utils: for camera
+ optdepends = libpulse: for audio/mic mute/unmute vol+/-
+ optdepends = brightnessctl: for brightness up and down
+ optdepends = xorg-xrdb: for autohidpi
+ optdepends = xorg-xrandr: for screen rotation
+ optdepends = xorg-xinput: for autorotation
+ optdepends = inotify-tools: for autorotation
+ optdepends = iio-sensor-proxy: for autorotation
+ optdepends = redshift: for night mode
+ optdepends = bluez-tools: for bluetooth
+ optdepends = networkmanager: for wifi and hotspot
+ optdepends = connman: for wifi and hotspot
+ optdepends = util-linux: for airplane mode
+ optdepends = xdg-utils: for lock screen (xdg-screensaver lock)
+ optdepends = systemd: for leave commands and gps services
+ optdepends = grep: used in scripts
+ provides = qwikaccess
+ conflicts = qwikaccess
+ source = git+https://github.com/librewish/qwikaccess.git
+ md5sums = SKIP
+
+pkgname = qwikaccess-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6212898d4536
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+_pkgname=qwikaccess
+pkgname=${_pkgname}-git
+pkgver=0.0.1.r0.02d5835
+pkgrel=1
+pkgdesc="A point and click Qt GUI for scripts we use frequently."
+arch=('any')
+url="https://github.com/librewish/qwikaccess"
+license=('GPL3')
+depends=('qt5-base' 'polkit')
+optdepends=(
+ 'ffmpeg: for screenshot & audio,screen,screencam recording'
+ 'v4l-utils: for camera'
+ 'libpulse: for audio/mic mute/unmute vol+/-'
+ 'brightnessctl: for brightness up and down'
+ 'xorg-xrdb: for autohidpi'
+ 'xorg-xrandr: for screen rotation'
+ 'xorg-xinput: for autorotation'
+ 'inotify-tools: for autorotation'
+ 'iio-sensor-proxy: for autorotation'
+ 'redshift: for night mode'
+ 'bluez-tools: for bluetooth'
+ 'networkmanager: for wifi and hotspot'
+ 'connman: for wifi and hotspot'
+ 'util-linux: for airplane mode'
+ 'xdg-utils: for lock screen (xdg-screensaver lock)'
+ 'systemd: for leave commands and gps services'
+ 'grep: used in scripts'
+)
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/librewish/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}