summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqsqcqs2024-03-16 09:32:01 -0700
committerqsqcqs2024-03-16 09:32:01 -0700
commit646b30b6a4ea924f526110cae1ac91be4bc57e3c (patch)
tree8103fa57c174e573e7a689f9022ae515951f41b2
downloadaur-646b30b6a4ea924f526110cae1ac91be4bc57e3c.tar.gz
pls
-rw-r--r--PKGBUILD23
-rw-r--r--qwq64
-rw-r--r--qwq-1.0-1-x86_64.pkg.tar.zstbin0 -> 11041 bytes
-rw-r--r--qwq-v1.0.tar.gzbin0 -> 716 bytes
-rw-r--r--uwu64
5 files changed, 151 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa7a443f44d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: imoutocon
+pkgname='qwq'
+pkgver=1.0
+pkgrel=1
+pkgdesc="uwu/qwq for terminal"
+arch=('x86_64')
+url="https://github.com/qsqcqs/qwq/tree"
+license=('GPL-3.0-or-later')
+depends=('python3')
+checkdepends=()
+optdepends=()
+replaces=('uwu-qwq')
+source=("https://github.com/qsqcqs/$pkgname/archive/refs/tags/qwq-v$pkgver.tar.gz")
+noextract=()
+validpgpkeys=()
+
+
+package() {
+ cd "$pkgname-$pkgname-v$pkgver"
+ sudo install -Dm755 uwu "/usr/bin/uwu"
+ sudo install -Dm755 qwq "/usr/bin/qwq"
+}
+sha256sums=('dc7bdb57e2a96bce1fa75eb17979d4a7b9993b1ebfbc1ea6f60a805741fba4d3')
diff --git a/qwq b/qwq
new file mode 100644
index 000000000000..4d7e756b77ef
--- /dev/null
+++ b/qwq
@@ -0,0 +1,64 @@
+#!/bin/python
+
+import re
+import sys
+b=0
+if len(sys.argv) > 1:
+ b=sys.argv[1:]
+ a=b[0]
+ b=b[1:]
+ while len(b) > 0:
+ a=a+' '+b[0]
+ b=b[1:]
+ a=re.sub("thats","nyas",a)
+ a=re.sub("pretty|beautiful","pwetti",a)
+ a=re.sub("rl","w",a)
+ a=re.sub("r","w",a)
+ a=re.sub("l","w",a)
+ a=re.sub("ow","ao",a)
+ a=re.sub("tha","nya",a)
+ a=re.sub("(?<=\b)this(?=\b)","dis",a)
+ a=re.sub("na","nya",a)
+ a=re.sub("th","f",a)
+ a=re.sub("(?<![b-df-hj-np-tv-xzB-DF-HJ-NP-TV-XZ])u","wu",a)
+ a=re.sub("y","yie",a)
+ a=re.sub("(?<![aeiouAEIOU])e[iya]","yei",a)
+ a=re.sub("(?<![aeiouAEIOU])ie","yie",a)
+ a=re.sub("(?<![aeiouAEIOU])a[e]","yae",a)
+ a=re.sub("(?<![aeiouAEIOU])ai","yai",a)
+ a=re.sub("(?<![aeiouAEIOU])o[ou]","yu",a)
+ a=re.sub("(?<![aeiouAEIOU])oe","yo",a)
+ a=re.sub("(?<![aeiouAEIOU])u[eu]","uwu",a)
+ a=re.sub("(?<![aeiouAEIOU])e[u]","uwu",a)
+ a=re.sub("o[uo]","ew",a)
+ print(a)
+ exit()
+
+while b==0:
+ try:
+ a=input()
+ a=re.sub("thats","nyas",a)
+ a=re.sub("pretty|beautiful","pwetti",a)
+ a=re.sub("rl","w",a)
+ a=re.sub("r","w",a)
+ a=re.sub("l","w",a)
+ a=re.sub("ow","ao",a)
+ a=re.sub("tha","nya",a)
+ a=re.sub("(?<=\b)this(?=\b)","dis",a)
+ a=re.sub("na","nya",a)
+ a=re.sub("th","f",a)
+ a=re.sub("(?<![b-df-hj-np-tv-xzB-DF-HJ-NP-TV-XZ])u","wu",a)
+ a=re.sub("y","yie",a)
+ a=re.sub("(?<![aeiouAEIOU])e[iya]","yei",a)
+ a=re.sub("(?<![aeiouAEIOU])ie","yie",a)
+ a=re.sub("(?<![aeiouAEIOU])a[e]","yae",a)
+ a=re.sub("(?<![aeiouAEIOU])ai","yai",a)
+ a=re.sub("(?<![aeiouAEIOU])o[ou]","yu",a)
+ a=re.sub("(?<![aeiouAEIOU])oe","yo",a)
+ a=re.sub("(?<![aeiouAEIOU])u[eu]","uwu",a)
+ a=re.sub("(?<![aeiouAEIOU])e[u]","uwu",a)
+ a=re.sub("o[uo]","ew",a)
+ print(a)
+ except EOFError:
+ b=1
+
diff --git a/qwq-1.0-1-x86_64.pkg.tar.zst b/qwq-1.0-1-x86_64.pkg.tar.zst
new file mode 100644
index 000000000000..715ed91a5f17
--- /dev/null
+++ b/qwq-1.0-1-x86_64.pkg.tar.zst
Binary files differ
diff --git a/qwq-v1.0.tar.gz b/qwq-v1.0.tar.gz
new file mode 100644
index 000000000000..5cc614004999
--- /dev/null
+++ b/qwq-v1.0.tar.gz
Binary files differ
diff --git a/uwu b/uwu
new file mode 100644
index 000000000000..4d7e756b77ef
--- /dev/null
+++ b/uwu
@@ -0,0 +1,64 @@
+#!/bin/python
+
+import re
+import sys
+b=0
+if len(sys.argv) > 1:
+ b=sys.argv[1:]
+ a=b[0]
+ b=b[1:]
+ while len(b) > 0:
+ a=a+' '+b[0]
+ b=b[1:]
+ a=re.sub("thats","nyas",a)
+ a=re.sub("pretty|beautiful","pwetti",a)
+ a=re.sub("rl","w",a)
+ a=re.sub("r","w",a)
+ a=re.sub("l","w",a)
+ a=re.sub("ow","ao",a)
+ a=re.sub("tha","nya",a)
+ a=re.sub("(?<=\b)this(?=\b)","dis",a)
+ a=re.sub("na","nya",a)
+ a=re.sub("th","f",a)
+ a=re.sub("(?<![b-df-hj-np-tv-xzB-DF-HJ-NP-TV-XZ])u","wu",a)
+ a=re.sub("y","yie",a)
+ a=re.sub("(?<![aeiouAEIOU])e[iya]","yei",a)
+ a=re.sub("(?<![aeiouAEIOU])ie","yie",a)
+ a=re.sub("(?<![aeiouAEIOU])a[e]","yae",a)
+ a=re.sub("(?<![aeiouAEIOU])ai","yai",a)
+ a=re.sub("(?<![aeiouAEIOU])o[ou]","yu",a)
+ a=re.sub("(?<![aeiouAEIOU])oe","yo",a)
+ a=re.sub("(?<![aeiouAEIOU])u[eu]","uwu",a)
+ a=re.sub("(?<![aeiouAEIOU])e[u]","uwu",a)
+ a=re.sub("o[uo]","ew",a)
+ print(a)
+ exit()
+
+while b==0:
+ try:
+ a=input()
+ a=re.sub("thats","nyas",a)
+ a=re.sub("pretty|beautiful","pwetti",a)
+ a=re.sub("rl","w",a)
+ a=re.sub("r","w",a)
+ a=re.sub("l","w",a)
+ a=re.sub("ow","ao",a)
+ a=re.sub("tha","nya",a)
+ a=re.sub("(?<=\b)this(?=\b)","dis",a)
+ a=re.sub("na","nya",a)
+ a=re.sub("th","f",a)
+ a=re.sub("(?<![b-df-hj-np-tv-xzB-DF-HJ-NP-TV-XZ])u","wu",a)
+ a=re.sub("y","yie",a)
+ a=re.sub("(?<![aeiouAEIOU])e[iya]","yei",a)
+ a=re.sub("(?<![aeiouAEIOU])ie","yie",a)
+ a=re.sub("(?<![aeiouAEIOU])a[e]","yae",a)
+ a=re.sub("(?<![aeiouAEIOU])ai","yai",a)
+ a=re.sub("(?<![aeiouAEIOU])o[ou]","yu",a)
+ a=re.sub("(?<![aeiouAEIOU])oe","yo",a)
+ a=re.sub("(?<![aeiouAEIOU])u[eu]","uwu",a)
+ a=re.sub("(?<![aeiouAEIOU])e[u]","uwu",a)
+ a=re.sub("o[uo]","ew",a)
+ print(a)
+ except EOFError:
+ b=1
+