summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-05-01 11:41:47 +0000
committerAntonio Rojas2019-05-01 11:41:47 +0000
commitf215770e27fefe7918c9daf514ae70700efd0586 (patch)
treea6471a87aeea3c3b4681bfdc27da44bbb42fbfe1
downloadaur-qwtplot3d.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD49
-rw-r--r--qwtplot3d-gcc44.patch12
-rw-r--r--qwtplot3d-qt-4.8.0.patch34
4 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e1741b853f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = qwtplot3d
+ pkgdesc = Qt/OpenGL-based C++ programming library containing 3d-widgets
+ pkgver = 0.2.7
+ pkgrel = 10
+ url = http://qwtplot3d.sourceforge.net/
+ arch = x86_64
+ license = custom:zlib
+ makedepends = mesa
+ makedepends = glu
+ depends = qt4
+ source = https://downloads.sourceforge.net/sourceforge/qwtplot3d/qwtplot3d-0.2.7.tgz
+ source = qwtplot3d-gcc44.patch
+ source = qwtplot3d-qt-4.8.0.patch
+ sha1sums = 4463fafb8420a91825e165da7a296aaabd70abea
+ sha1sums = 52fa169b651a98550f8a8391ddf52e0eaeb2c215
+ sha1sums = 8dcafdc9753b0f2eeea2f1e96efa6e8d3d956005
+
+pkgname = qwtplot3d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..412039718b71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Ronald van Haren <ronald@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=qwtplot3d
+pkgver=0.2.7
+pkgrel=10
+pkgdesc="Qt/OpenGL-based C++ programming library containing 3d-widgets"
+arch=("x86_64")
+license=('custom:zlib')
+url="http://qwtplot3d.sourceforge.net/"
+depends=('qt4')
+makedepends=('mesa' 'glu')
+source=("https://downloads.sourceforge.net/sourceforge/qwtplot3d/qwtplot3d-$pkgver.tgz"
+ qwtplot3d-gcc44.patch qwtplot3d-qt-4.8.0.patch)
+sha1sums=('4463fafb8420a91825e165da7a296aaabd70abea'
+ '52fa169b651a98550f8a8391ddf52e0eaeb2c215'
+ '8dcafdc9753b0f2eeea2f1e96efa6e8d3d956005')
+
+prepare() {
+ cd ${pkgname}
+ patch -p1 -i "${srcdir}"/qwtplot3d-gcc44.patch
+ patch -p1 -i "${srcdir}"/qwtplot3d-qt-4.8.0.patch
+}
+
+build() {
+ cd ${pkgname}
+ # build qwt:
+ qmake-qt4 qwtplot3d.pro
+ make
+}
+
+package() {
+ cd ${pkgname}
+
+ # install qwtplot3d: (by hand, because the Makefile do not provide a "install:")
+ install -d "${pkgdir}"/usr/{include/qwtplot3d,lib}
+
+ for n in include/* ; do
+ cp -d $n "${pkgdir}"/usr/include/qwtplot3d
+ done
+
+ for n in lib/libqwtplot3d.so* ; do
+ cp -d $n "${pkgdir}"/usr/lib
+ done
+
+ # install custom license
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+
diff --git a/qwtplot3d-gcc44.patch b/qwtplot3d-gcc44.patch
new file mode 100644
index 000000000000..a76fe831ab91
--- /dev/null
+++ b/qwtplot3d-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur qwtplot3d-orig/include/qwt3d_function.h qwtplot3d/include/qwt3d_function.h
+--- qwtplot3d-orig/include/qwt3d_function.h 2009-07-25 18:18:58.000000000 -0400
++++ qwtplot3d/include/qwt3d_function.h 2009-07-25 18:19:19.000000000 -0400
+@@ -2,6 +2,7 @@
+ #define qwt3d_function_h__2004_03_05_13_51_begin_guarded_code
+
+ #include "qwt3d_gridmapping.h"
++#include <cstdio>
+
+ namespace Qwt3D
+ {
+Only in qwtplot3d/tmp: qwt3d_function.o
diff --git a/qwtplot3d-qt-4.8.0.patch b/qwtplot3d-qt-4.8.0.patch
new file mode 100644
index 000000000000..ae10f48f0707
--- /dev/null
+++ b/qwtplot3d-qt-4.8.0.patch
@@ -0,0 +1,34 @@
+diff -urbN qwtplot3d/include/qwt3d_io_gl2ps.h qwtplot3d.patched/include/qwt3d_io_gl2ps.h
+--- qwtplot3d/include/qwt3d_io_gl2ps.h 2005-07-10 16:54:52.000000000 +0300
++++ qwtplot3d.patched/include/qwt3d_io_gl2ps.h 2012-01-21 22:15:20.000000000 +0200
+@@ -2,12 +2,7 @@
+ #define qwt3d_io_gl2ps_h__2004_05_07_01_16_begin_guarded_code
+
+ #include <time.h>
+-
+-#if QT_VERSION < 0x040000
+-#include <qgl.h>
+-#else
+-#include <QtOpenGL/qgl.h>
+-#endif
++#include <QtOpenGL>
+
+ #include "qwt3d_types.h"
+ #include "qwt3d_io.h"
+diff -urbN qwtplot3d/include/qwt3d_openglhelper.h qwtplot3d.patched/include/qwt3d_openglhelper.h
+--- qwtplot3d/include/qwt3d_openglhelper.h 2005-07-19 17:40:28.000000000 +0300
++++ qwtplot3d.patched/include/qwt3d_openglhelper.h 2012-01-21 22:29:56.000000000 +0200
+@@ -2,11 +2,8 @@
+ #define __openglhelper_2003_06_06_15_49__
+
+ #include "qglobal.h"
+-#if QT_VERSION < 0x040000
+-#include <qgl.h>
+-#else
+-#include <QtOpenGL/qgl.h>
+-#endif
++#include <QtOpenGL>
++#include <GL/glu.h>
+
+ namespace Qwt3D
+ {