summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM. Scholz2019-07-05 14:31:21 +0200
committerM. Scholz2019-07-05 14:31:21 +0200
commit559e179edb636ceb935db591d0769717a0c59b1d (patch)
tree2804e29f935122a110a53f5bf6c151ce4cac3e89
downloadaur-559e179edb636ceb935db591d0769717a0c59b1d.tar.gz
initial
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD55
-rw-r--r--qwtplot3d-gcc44.patch12
-rw-r--r--qwtplot3d-qt-4.8.0.patch34
-rw-r--r--qwtplot3d-qt5.patch19
5 files changed, 141 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bed20203721b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = qwtplot3d-qt5
+ pkgdesc = Qt/OpenGL-based C++ programming library containing 3d-widgets
+ pkgver = 0.2.7
+ pkgrel = 2
+ url = http://qwtplot3d.sourceforge.net/
+ arch = x86_64
+ license = custom:zlib
+ makedepends = mesa
+ makedepends = glu
+ depends = qt5-base
+ source = https://downloads.sourceforge.net/sourceforge/qwtplot3d/qwtplot3d-0.2.7.tgz
+ source = qwtplot3d-gcc44.patch
+ source = qwtplot3d-qt-4.8.0.patch
+ source = qwtplot3d-qt5.patch
+ sha1sums = 4463fafb8420a91825e165da7a296aaabd70abea
+ sha1sums = 52fa169b651a98550f8a8391ddf52e0eaeb2c215
+ sha1sums = 8dcafdc9753b0f2eeea2f1e96efa6e8d3d956005
+ sha1sums = f0048a7fb030165a2173a3bf6fdadbf73d571bf4
+
+pkgname = qwtplot3d-qt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfbb9b91eaa9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Mirko Scholz
+# modeled after qwtplot3d
+# Contributor: Ronald van Haren <ronald@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=qwtplot3d-qt5
+pkgver=0.2.7
+pkgrel=2
+pkgdesc="Qt/OpenGL-based C++ programming library containing 3d-widgets"
+arch=("x86_64")
+license=('custom:zlib')
+url="http://qwtplot3d.sourceforge.net/"
+depends=('qt5-base')
+makedepends=('mesa' 'glu')
+source=("https://downloads.sourceforge.net/sourceforge/qwtplot3d/qwtplot3d-$pkgver.tgz"
+ qwtplot3d-gcc44.patch
+ qwtplot3d-qt-4.8.0.patch
+ qwtplot3d-qt5.patch)
+sha1sums=('4463fafb8420a91825e165da7a296aaabd70abea'
+ '52fa169b651a98550f8a8391ddf52e0eaeb2c215'
+ '8dcafdc9753b0f2eeea2f1e96efa6e8d3d956005'
+ 'f0048a7fb030165a2173a3bf6fdadbf73d571bf4')
+
+prepare() {
+ cd qwtplot3d
+ patch -p1 -i "${srcdir}"/qwtplot3d-gcc44.patch
+ patch -p1 -i "${srcdir}"/qwtplot3d-qt-4.8.0.patch
+ patch -p1 -i "${srcdir}"/qwtplot3d-qt5.patch
+}
+
+build() {
+ cd qwtplot3d
+ # build qwt:
+ qmake-qt5 qwtplot3d.pro
+ make
+}
+
+package() {
+ cd qwtplot3d
+
+ # install qwtplot3d: (by hand, because the Makefile do not provide a "install:")
+ install -d "${pkgdir}"/usr/{include/qt/qwtplot3d-qt5,lib}
+
+ for n in include/* ; do
+ cp -d $n "${pkgdir}"/usr/include/qt/qwtplot3d-qt5
+ done
+
+ for n in lib/libqwtplot3d-qt5.so* ; do
+ cp -d $n "${pkgdir}"/usr/lib
+ done
+
+ # install custom license
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+
diff --git a/qwtplot3d-gcc44.patch b/qwtplot3d-gcc44.patch
new file mode 100644
index 000000000000..a76fe831ab91
--- /dev/null
+++ b/qwtplot3d-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur qwtplot3d-orig/include/qwt3d_function.h qwtplot3d/include/qwt3d_function.h
+--- qwtplot3d-orig/include/qwt3d_function.h 2009-07-25 18:18:58.000000000 -0400
++++ qwtplot3d/include/qwt3d_function.h 2009-07-25 18:19:19.000000000 -0400
+@@ -2,6 +2,7 @@
+ #define qwt3d_function_h__2004_03_05_13_51_begin_guarded_code
+
+ #include "qwt3d_gridmapping.h"
++#include <cstdio>
+
+ namespace Qwt3D
+ {
+Only in qwtplot3d/tmp: qwt3d_function.o
diff --git a/qwtplot3d-qt-4.8.0.patch b/qwtplot3d-qt-4.8.0.patch
new file mode 100644
index 000000000000..ae10f48f0707
--- /dev/null
+++ b/qwtplot3d-qt-4.8.0.patch
@@ -0,0 +1,34 @@
+diff -urbN qwtplot3d/include/qwt3d_io_gl2ps.h qwtplot3d.patched/include/qwt3d_io_gl2ps.h
+--- qwtplot3d/include/qwt3d_io_gl2ps.h 2005-07-10 16:54:52.000000000 +0300
++++ qwtplot3d.patched/include/qwt3d_io_gl2ps.h 2012-01-21 22:15:20.000000000 +0200
+@@ -2,12 +2,7 @@
+ #define qwt3d_io_gl2ps_h__2004_05_07_01_16_begin_guarded_code
+
+ #include <time.h>
+-
+-#if QT_VERSION < 0x040000
+-#include <qgl.h>
+-#else
+-#include <QtOpenGL/qgl.h>
+-#endif
++#include <QtOpenGL>
+
+ #include "qwt3d_types.h"
+ #include "qwt3d_io.h"
+diff -urbN qwtplot3d/include/qwt3d_openglhelper.h qwtplot3d.patched/include/qwt3d_openglhelper.h
+--- qwtplot3d/include/qwt3d_openglhelper.h 2005-07-19 17:40:28.000000000 +0300
++++ qwtplot3d.patched/include/qwt3d_openglhelper.h 2012-01-21 22:29:56.000000000 +0200
+@@ -2,11 +2,8 @@
+ #define __openglhelper_2003_06_06_15_49__
+
+ #include "qglobal.h"
+-#if QT_VERSION < 0x040000
+-#include <qgl.h>
+-#else
+-#include <QtOpenGL/qgl.h>
+-#endif
++#include <QtOpenGL>
++#include <GL/glu.h>
+
+ namespace Qwt3D
+ {
diff --git a/qwtplot3d-qt5.patch b/qwtplot3d-qt5.patch
new file mode 100644
index 000000000000..3af95c31d36c
--- /dev/null
+++ b/qwtplot3d-qt5.patch
@@ -0,0 +1,19 @@
+diff -u10 -r qwtplot3d/qwtplot3d.pro qwtplot3d.1/qwtplot3d.pro
+--- qwtplot3d/qwtplot3d.pro 2007-05-20 17:51:50.000000000 +0200
++++ qwtplot3d.1/qwtplot3d.pro 2019-07-05 13:12:47.367738983 +0200
+@@ -1,14 +1,14 @@
+ # pro file for building the makefile for qwtplot3d
+ #
+
+-TARGET = qwtplot3d
++TARGET = qwtplot3d-qt5
+ TEMPLATE = lib
+ CONFIG += qt warn_on opengl thread zlib debug
+ MOC_DIR = tmp
+ OBJECTS_DIR = tmp
+ INCLUDEPATH = include
+ DEPENDPATH = include src
+ DESTDIR = lib
+ #DESTDIR = ../../../lib
+ QT += opengl
+