summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2017-02-20 22:33:41 -0600
committerDoug Newgard2017-02-20 22:39:42 -0600
commitfe44e6ba59a8c524f87c0ccd124694854ada8817 (patch)
treea723d7b9127c1594fccfd03c62bec477f8c243db
downloadaur-fe44e6ba59a8c524f87c0ccd124694854ada8817.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5336fe7a5b4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qwtpolar-qt4
+ pkgdesc = Qwt library that contains classes for displaying values on a polar coordinate system - Qt4 version
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://qwtpolar.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ depends = glibc
+ depends = qt4
+ depends = qwt-qt4
+ source = https://sourceforge.net/projects/qwtpolar/files/qwtpolar/1.1.1/qwtpolar-1.1.1.tar.bz2
+ sha1sums = 38edf5220c971eef0e88fcc6db7c718e6198ccac
+
+pkgname = qwtpolar-qt4
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..71a9d16c2b38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*/
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5f86f24d888
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Doug Newgard <scimmia at archlinux dot info>
+# Contributor: SaultDon <sault.don gmail>
+# Contributor: Gunther Schulz < mail at guntherschulz.de >
+# Contributor: Kévin Guilloy <kevin at guilloy dot ath dot cx>
+
+pkgname=qwtpolar-qt4
+_pkgname=qwtpolar
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='Qwt library that contains classes for displaying values on a polar coordinate system - Qt4 version'
+arch=('i686' 'x86_64')
+url='http://qwtpolar.sourceforge.net/'
+license=('custom')
+depends=('gcc-libs' 'glibc' 'qt4' 'qwt-qt4')
+source=("https://sourceforge.net/projects/qwtpolar/files/$_pkgname/$pkgver/$_pkgname-$pkgver.tar.bz2")
+sha1sums=('38edf5220c971eef0e88fcc6db7c718e6198ccac')
+
+prepare() {
+ cd $_pkgname-$pkgver
+
+ sed -e '/^\s*QWT_POLAR_INSTALL_PREFIX/ s|=.*|= /usr|' \
+ -e '/^QWT_POLAR_INSTALL_DOCS/ s|^|#|' \
+ -e '/^QWT_POLAR_INSTALL_HEADERS/ s|include|&/qwt-qt4|' \
+ -e '/^QWT_POLAR_INSTALL_PLUGINS/ s|plugins/designer|lib/qt4/&|' \
+ -e '/^QWT_POLAR_INSTALL_FEATURES/ s|features|share/qt4/mkspecs/&|' \
+ -e '/QwtPolarExamples/ s/^/#/' \
+ -i qwtpolarconfig.pri
+
+ sed -i '/^\s*\(LIBRARY_NAME\|LIB_NAME\)/ s/$/-qt4/' qwtpolarfunctions.pri
+}
+
+build() {
+ cd $_pkgname-$pkgver
+
+ qmake-qt4 qwtpolar.pro
+
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
+}