summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYannick Le Guen2015-06-12 17:56:08 +0200
committerYannick Le Guen2015-06-12 17:56:08 +0200
commit1bb7cf805426bf6d7b22203f4ac6cd671b165ad0 (patch)
tree5b803cf5d5335480652cf76c9855ef5bd346bd21
downloadaur-1bb7cf805426bf6d7b22203f4ac6cd671b165ad0.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cb94aaac5ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = qxmpp
+ pkgdesc = An XMPP client library based on Qt & C++
+ pkgver = 0.7.5
+ pkgrel = 4
+ url = http://code.google.com/p/qxmpp/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = qt4>=4.5
+ optdepends = speex: required to enable speex audio codec
+ optdepends = libvpx: required to enable vpx video codec
+ optdepends = libtheora: required to enable theora video codec
+ conflicts = qxmpp-git
+ conflicts = qxmpp-leechcraft-git
+ source = http://qxmpp.googlecode.com/files/qxmpp-0.7.5.tar.gz
+ sha1sums = 184f658fa5b2e001f8fb24ad7c5bfa93ddfb2eb2
+
+pkgname = qxmpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3b5c19b0046
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Spike29 <leguen.yannick@gmail.com>
+# Contributor: Samir Faci <csgeek@archlinux.us>
+# Contributor: Timothée Ravier <tim@siosm.fr>
+
+pkgname='qxmpp'
+pkgver='0.7.5'
+pkgrel='4'
+pkgdesc='An XMPP client library based on Qt & C++'
+arch=('i686' 'x86_64')
+url='http://code.google.com/p/qxmpp/'
+license=('LGPL2.1')
+depends=('qt4>=4.5')
+optdepends=('speex: required to enable speex audio codec'
+ 'libvpx: required to enable vpx video codec'
+ 'libtheora: required to enable theora video codec')
+conflicts=('qxmpp-git' 'qxmpp-leechcraft-git')
+source=("http://qxmpp.googlecode.com/files/$pkgname-$pkgver.tar.gz")
+sha1sums=('184f658fa5b2e001f8fb24ad7c5bfa93ddfb2eb2')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ [ -d build ] || mkdir build && cd build
+ qmake-qt4 PREFIX=/usr ..
+
+ # In order to enable speex audio codec, vpx video codec or theora video codec,
+ # add QXMPP_USE_SPEEX=1, QXMPP_USE_VPX=1 and QXMPP_USE_THEORA=1 to qmake arguments.
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/build"
+ make INSTALL_ROOT="$pkgdir" install
+}