summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2019-01-09 00:32:30 +0100
committerJake2019-01-09 00:46:46 +0100
commit3951034af40a4ff81675a48bb27bf188342271ba (patch)
tree11549270220f74a6bbd6750c321e490c9ae1c9ee
parente343fb7d05364dbb3a165727f2a0e4934e17d4a7 (diff)
downloadaur-3951034af40a4ff81675a48bb27bf188342271ba.tar.gz
Update to 1.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 754fc241384a..ac2c3b4db212 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qxmpp
pkgdesc = Cross-platform C++ XMPP client and server library
- pkgver = 0.9.3
- pkgrel = 2
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://github.com/qxmpp-project/qxmpp
arch = i686
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = qxmpp
optdepends = libvpx: required to enable vpx video codec
optdepends = libtheora: required to enable theora video codec
conflicts = qxmpp-qt5
- source = https://github.com/qxmpp-project/qxmpp/archive/v0.9.3.tar.gz
- sha1sums = f9391bedd5153ae19f68f25276bf2624c5020d09
+ source = https://github.com/qxmpp-project/qxmpp/archive/v1.0.0.tar.gz
+ sha1sums = 4b68d569494e7daf3035c383bbafbd312986b63d
pkgname = qxmpp
diff --git a/PKGBUILD b/PKGBUILD
index 3614618df118..91fadcaed189 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Timothée Ravier <tim@siosm.fr>
pkgname='qxmpp'
-pkgver='0.9.3'
-pkgrel=2
+pkgver='1.0.0'
+pkgrel=1
pkgdesc='Cross-platform C++ XMPP client and server library'
arch=('i686' 'x86_64')
url='https://github.com/qxmpp-project/qxmpp'
@@ -18,23 +18,23 @@ optdepends=('doxygen: required to build the HTML documentation'
'libtheora: required to enable theora video codec')
conflicts=('qxmpp-qt5')
source=("${url}/archive/v${pkgver}.tar.gz")
-sha1sums=('f9391bedd5153ae19f68f25276bf2624c5020d09')
+sha1sums=('4b68d569494e7daf3035c383bbafbd312986b63d')
build() {
cd "$srcdir/$pkgname-$pkgver/"
[ -d build ] || mkdir build && cd build
- # In order to build the HTML documentation,
- # add QXMPP_USE_DOXYGEN=1 to qmake arguments
-
+ # In order to build the HTML documentation (requires doxygen)
+ # add BUILD_DOCUMENTATION to CMake arguments
+
# In order to enable opus & speex audio codecs, and vpx & theora video codecs,
- # add QXMPP_USE_OPUS=1, QXMPP_USE_SPEEX=1, QXMPP_USE_VPX=1 and QXMPP_USE_THEORA=1 to qmake arguments
-
- qmake-qt5 PREFIX=/usr ..
+ # add WITH_OPUS, WITH_SPEEX, WITH_THEORA, WITH_VPX to CMake arguments
+
+ cmake ..
make
}
package() {
cd "$srcdir/$pkgname-$pkgver/build"
- make INSTALL_ROOT="$pkgdir" install
+ make DESTDIR="$pkgdir" install
}