summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2018-06-13 05:22:04 +0200
committerJan Cholasta2018-06-13 05:22:04 +0200
commit79fb0dbc5d550d75cf3cf12c719e14a58693d549 (patch)
tree16316c6d5562f1f4700394251fa6a3cc5f10d8ab
parent370460ae86f83016af06b6209e2503c3ae7e6d2f (diff)
parent4f6f557f5d1cc908660c1f490e2bc15cf12e12bd (diff)
downloadaur-79fb0dbc5d550d75cf3cf12c719e14a58693d549.tar.gz
Merge remote-tracking branch 'gzdoom-git/master'
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Fix-soundfont-search-path.patch29
-rw-r--r--PKGBUILD20
3 files changed, 48 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95eb5d062779..96f7c13496d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,8 +16,8 @@ pkgbase = qzdoom-git
makedepends = gtk3
depends = hicolor-icon-theme
depends = libgl
- depends = libjpeg
depends = libgme
+ depends = libjpeg
depends = sdl2
optdepends = blasphemer-wad: Blasphemer (free Heretic) game data
optdepends = chexquest3-wad: Chex Quest 3 game data
@@ -36,17 +36,19 @@ pkgbase = qzdoom-git
optdepends = libsndfile: WAV/FLAC/OGG audio support
optdepends = mpg123: MP3 audio support
optdepends = openal: in-game sound
+ optdepends = soundfont-fluid: FluidR3 soundfont for FluidSynth
optdepends = strife0-wad: Strife shareware game data
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
- optdepends = timidity++: Timidity MIDI device
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
provides = qzdoom
conflicts = qzdoom
source = qzdoom::git://github.com/raa-eruanna/qzdoom.git
source = qzdoom.desktop
+ source = 0001-Fix-soundfont-search-path.patch
sha256sums = SKIP
sha256sums = 0b3bcbe2cdebda2fed887b796f4ff0fa51f3d544e80cab16b3b1cbd7813b7e04
+ sha256sums = 26cd2fa2285bcf4c9147a7f1763c217c3e7056bd4a729824f9af0104f6f410c9
pkgname = qzdoom-git
diff --git a/0001-Fix-soundfont-search-path.patch b/0001-Fix-soundfont-search-path.patch
new file mode 100644
index 000000000000..55b948c6870c
--- /dev/null
+++ b/0001-Fix-soundfont-search-path.patch
@@ -0,0 +1,29 @@
+From 6a33dc9c7d85f5974a0d7bad6f376099c52507be Mon Sep 17 00:00:00 2001
+From: Jan Cholasta <jan@cholasta.net>
+Date: Mon, 5 Mar 2018 16:17:24 +0100
+Subject: [PATCH] Fix soundfont search path
+
+---
+ src/gameconfigfile.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
+index c2655c359..caa221cfe 100644
+--- a/src/gameconfigfile.cpp
++++ b/src/gameconfigfile.cpp
+@@ -181,10 +181,12 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey("Path", "$PROGDIR/soundfonts", true);
+ #else
+ SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
++ SetValueForKey("Path", SHARE_DIR "/soundfonts", true);
+ SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
++ SetValueForKey("Path", "/usr/share/soundfonts", true);
+ #endif
+ }
+
+--
+2.16.2
+
diff --git a/PKGBUILD b/PKGBUILD
index ae605a38d597..cfb44531294a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@ url='http://www.zdoom.org/'
license=('BSD' 'custom:dumb' 'GPL3' 'LGPL3')
depends=('hicolor-icon-theme'
'libgl'
- 'libjpeg'
'libgme'
+ 'libjpeg'
'sdl2')
makedepends=('cmake'
'desktop-file-utils'
@@ -35,17 +35,19 @@ optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'libsndfile: WAV/FLAC/OGG audio support'
'mpg123: MP3 audio support'
'openal: in-game sound'
+ 'soundfont-fluid: FluidR3 soundfont for FluidSynth'
'strife0-wad: Strife shareware game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
- 'timidity++: Timidity MIDI device'
'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
'xorg-xmessage: crash dialog (other)')
provides=("${_name}")
conflicts=("${_name}")
source=("${_name}::git://github.com/raa-eruanna/${_name}.git"
- "${_name}.desktop")
+ "${_name}.desktop"
+ '0001-Fix-soundfont-search-path.patch')
sha256sums=('SKIP'
- '0b3bcbe2cdebda2fed887b796f4ff0fa51f3d544e80cab16b3b1cbd7813b7e04')
+ '0b3bcbe2cdebda2fed887b796f4ff0fa51f3d544e80cab16b3b1cbd7813b7e04'
+ '26cd2fa2285bcf4c9147a7f1763c217c3e7056bd4a729824f9af0104f6f410c9')
pkgver() {
cd $_name
@@ -53,6 +55,12 @@ pkgver() {
git describe --tags --match 'q*' | sed -r 's/^q//;s/-/+/g'
}
+prepare() {
+ cd $_name
+
+ patch -p1 -i"$srcdir"/0001-Fix-soundfont-search-path.patch
+}
+
build() {
cd $_name
@@ -71,11 +79,13 @@ package() {
cd $_name
make install DESTDIR="$pkgdir"
+ install -D -m644 soundfonts/gzdoom.sf2 \
+ "$pkgdir"/usr/share/$_name/soundfonts/gzdoom.sf2
desktop-file-install --dir="$pkgdir"/usr/share/applications \
"$srcdir"/${_name}.desktop
install -D -m644 src/posix/zdoom.xpm \
- "$pkgdir"/usr/share/icons/hicolor/48x48/apps/${_name}.xpm
+ "$pkgdir"/usr/share/icons/hicolor/256x256/apps/${_name}.xpm
install -d "$pkgdir"/usr/share/licenses
ln -s /usr/share/doc/$_name/licenses "$pkgdir"/usr/share/licenses/$pkgname