summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2018-11-17 07:10:44 +0100
committerJan Cholasta2018-11-17 07:10:44 +0100
commit6c563566be30aaf8d65a8e8eab80515c9d3b2409 (patch)
tree32c29a88a55cdb4df30a60ffe2ab3935f3aebd81
parent9abd25f1c235f0a1bc19f0a8c4f31e048b702c8b (diff)
parent850fa41e49fa026418f00159bb7823f45a1b4f2b (diff)
downloadaur-6c563566be30aaf8d65a8e8eab80515c9d3b2409.tar.gz
Merge remote-tracking branch 'gzdoom-git/master'
-rw-r--r--.SRCINFO2
-rw-r--r--0001-Fix-soundfont-search-path.patch20
-rw-r--r--PKGBUILD6
3 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0546f111fedb..39154cd1a745 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -48,7 +48,7 @@ pkgbase = qzdoom-git
source = 0001-Fix-soundfont-search-path.patch
sha256sums = SKIP
sha256sums = 0b3bcbe2cdebda2fed887b796f4ff0fa51f3d544e80cab16b3b1cbd7813b7e04
- sha256sums = b0e621a39e0a050ce119fb4bea888afc7a02039ee9f37a2a5b518e4fe924b3f1
+ sha256sums = 11323f98caadb086b35cce1697744eeba53c96a3f4f9a8c9184ed23e6fb1ea61
pkgname = qzdoom-git
diff --git a/0001-Fix-soundfont-search-path.patch b/0001-Fix-soundfont-search-path.patch
index 4209ab9f26fe..0c1ac9da73fd 100644
--- a/0001-Fix-soundfont-search-path.patch
+++ b/0001-Fix-soundfont-search-path.patch
@@ -1,29 +1,33 @@
-From 6147e4496a26f0571a2918bbc82b4b1483df8545 Mon Sep 17 00:00:00 2001
+From c70f3a7973eef99c6709f11be75d7fe1bdc29efd Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Mon, 5 Mar 2018 16:17:24 +0100
Subject: [PATCH] Fix soundfont search path
---
- src/gameconfigfile.cpp | 2 ++
- 1 file changed, 2 insertions(+)
+ src/gameconfigfile.cpp | 3 +++
+ 1 file changed, 3 insertions(+)
diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index cb47c3597..452fd4160 100644
+index 2979420f9..c8f22895c 100644
--- a/src/gameconfigfile.cpp
+++ b/src/gameconfigfile.cpp
-@@ -143,10 +143,12 @@ FGameConfigFile::FGameConfigFile ()
- SetValueForKey("Path", "$PROGDIR/soundfonts", true);
+@@ -149,6 +149,8 @@ FGameConfigFile::FGameConfigFile ()
#else
SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
+ SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
+ SetValueForKey("Path", SHARE_DIR "/soundfonts", true);
++ SetValueForKey("Path", SHARE_DIR "/fm_banks", true);
SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/local/share/doom/fm_banks", true);
SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
- SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+@@ -157,6 +159,7 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/games/doom/fm_banks", true);
+ SetValueForKey("Path", "/usr/share/soundfonts", true);
#endif
}
--
-2.18.0
+2.19.0
diff --git a/PKGBUILD b/PKGBUILD
index 0cdef3d47665..2bddb1143b69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,7 +47,7 @@ source=("${_name}::git://github.com/raa-eruanna/${_name}.git"
'0001-Fix-soundfont-search-path.patch')
sha256sums=('SKIP'
'0b3bcbe2cdebda2fed887b796f4ff0fa51f3d544e80cab16b3b1cbd7813b7e04'
- 'b0e621a39e0a050ce119fb4bea888afc7a02039ee9f37a2a5b518e4fe924b3f1')
+ '11323f98caadb086b35cce1697744eeba53c96a3f4f9a8c9184ed23e6fb1ea61')
pkgver() {
cd $_name
@@ -81,6 +81,10 @@ package() {
make install DESTDIR="$pkgdir"
install -D -m644 soundfonts/gzdoom.sf2 \
"$pkgdir"/usr/share/$_name/soundfonts/gzdoom.sf2
+ install -D -m644 fm_banks/GENMIDI.GS.wopl \
+ "$pkgdir"/usr/share/$_name/fm_banks/GENMIDI.GS.wopl
+ install -D -m644 fm_banks/gs-by-papiezak-and-sneakernets.wopn \
+ "$pkgdir"/usr/share/$_name/fm_banks/gs-by-papiezak-and-sneakernets.wopn
desktop-file-install --dir="$pkgdir"/usr/share/applications \
"$srcdir"/${_name}.desktop