summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2017-01-11 20:55:13 +0100
committerJan Cholasta2017-01-11 20:55:13 +0100
commitad316e6728669afe3b9fa3ff718f1816d58d684e (patch)
treee71ad8e5befa6c586c26898d0de5a72f06b0e69d
downloadaur-ad316e6728669afe3b9fa3ff718f1816d58d684e.tar.gz
qzdoom-git-1.3pre.182.g3f8e5d26b-1
-rw-r--r--.SRCINFO57
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD137
-rw-r--r--launcher.desktop10
4 files changed, 213 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81c9d3ab57da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,57 @@
+pkgbase = qzdoom-git
+ pkgdesc = Advanced Doom source port with true color renderer (git version)
+ pkgver = 1.3pre.182.g3f8e5d26b
+ pkgrel = 1
+ url = http://www.zdoom.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = custom:BUILD
+ license = custom:doom
+ license = custom:dumb
+ license = LGPL
+ makedepends = cmake
+ makedepends = desktop-file-utils
+ makedepends = fluidsynth
+ makedepends = git
+ makedepends = gtk3
+ makedepends = imagemagick
+ makedepends = llvm
+ makedepends = openal
+ makedepends = xdg-utils
+ depends = hicolor-icon-theme
+ depends = libgl
+ depends = libjpeg
+ depends = libgme
+ depends = libsndfile
+ depends = mpg123
+ depends = sdl2
+ optdepends = blasphemer-wad: Blasphemer (free Heretic) game data
+ optdepends = chexquest3-wad: Chex Quest 3 game data
+ optdepends = doom1-wad: Doom shareware game data
+ optdepends = fluidsynth: FluidSynth MIDI device
+ optdepends = freedm: FreeDM game data
+ optdepends = freedoom1: Freedoom: Phase 1 game data
+ optdepends = freedoom2: Freedoom: Phase 2 game data
+ optdepends = gtk3: IWAD selection dialog
+ optdepends = gxmessage: crash dialog (GNOME)
+ optdepends = hacx-wad: HacX game data
+ optdepends = harmony-wad: Harmony game data
+ optdepends = heretic1-wad: Heretic shareware game data
+ optdepends = hexen1-wad: Hexen demo game data
+ optdepends = kdialog: crash dialog (KDE)
+ optdepends = openal: OpenAL sound backend
+ optdepends = strife0-wad: Strife shareware game data
+ optdepends = square1-wad: The Adventures of Square, Episode 1 game data
+ optdepends = timidity++: Timidity MIDI device
+ optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
+ optdepends = xorg-xmessage: crash dialog (other)
+ provides = qzdoom
+ conflicts = qzdoom
+ source = qzdoom::git://github.com/raa-eruanna/qzdoom.git
+ source = launcher.desktop
+ sha256sums = SKIP
+ sha256sums = 0b3bcbe2cdebda2fed887b796f4ff0fa51f3d544e80cab16b3b1cbd7813b7e04
+
+pkgname = qzdoom-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d1345b55fae9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+qzdoom
+
+/*.tar.gz
+/*.tar.bz2
+/*.tar.xz
+/*.zip
+/*.7z
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..390a540fa2f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,137 @@
+# Maintainer: Jan Cholasta <grubber at grubber cz>
+
+# Build without fmodex:
+_fmodex=
+# Build with fmodex:
+#_fmodex=fmodex
+
+_name=qzdoom
+pkgname=${_name}-git
+pkgver=1.3pre.182.g3f8e5d26b
+pkgrel=1
+pkgdesc='Advanced Doom source port with true color renderer (git version)'
+arch=('i686' 'x86_64')
+url='http://www.zdoom.org/'
+license=('BSD' 'custom:BUILD' 'custom:doom' 'custom:dumb' 'LGPL')
+depends=(${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
+ 'hicolor-icon-theme'
+ 'libgl'
+ 'libjpeg'
+ 'libgme'
+ 'libsndfile'
+ 'mpg123'
+ 'sdl2')
+makedepends=('cmake'
+ 'desktop-file-utils'
+ 'fluidsynth'
+ 'git'
+ 'gtk3'
+ 'imagemagick'
+ 'llvm'
+ 'openal'
+ 'xdg-utils')
+optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
+ 'chexquest3-wad: Chex Quest 3 game data'
+ 'doom1-wad: Doom shareware game data'
+ 'fluidsynth: FluidSynth MIDI device'
+ 'freedm: FreeDM game data'
+ 'freedoom1: Freedoom: Phase 1 game data'
+ 'freedoom2: Freedoom: Phase 2 game data'
+ 'gtk3: IWAD selection dialog'
+ 'gxmessage: crash dialog (GNOME)'
+ 'hacx-wad: HacX game data'
+ 'harmony-wad: Harmony game data'
+ 'heretic1-wad: Heretic shareware game data'
+ 'hexen1-wad: Hexen demo game data'
+ 'kdialog: crash dialog (KDE)'
+ 'openal: OpenAL sound backend'
+ 'strife0-wad: Strife shareware game data'
+ 'square1-wad: The Adventures of Square, Episode 1 game data'
+ 'timidity++: Timidity MIDI device'
+ 'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
+ 'xorg-xmessage: crash dialog (other)')
+provides=("${_name}")
+conflicts=("${_name}")
+source=("${_name}::git://github.com/raa-eruanna/${_name}.git"
+ 'launcher.desktop')
+sha256sums=('SKIP'
+ '0b3bcbe2cdebda2fed887b796f4ff0fa51f3d544e80cab16b3b1cbd7813b7e04')
+
+pkgver() {
+ cd $_name
+
+ git describe --long --tags --match 'q*' | sed -r 's/^q//;s/([^-]*-g)/\1/;s/-/./g'
+}
+
+build() {
+ cd $_name
+
+ local _nofmod _fmodincdir _fmodlib
+
+ if [[ -n "${_fmodex}" ]]; then
+ _nofmod=OFF
+ _fmodincdir=$(LC_ALL=C pacman -Ql $_fmodex | grep -Eo '/usr/include/fmodex[^/]*/$')
+ _fmodlib=$(LC_ALL=C pacman -Ql $_fmodex | grep -Eo '/usr/lib/libfmodex-[^/]*\.so$')
+ else
+ _nofmod=ON
+ fi
+
+ cmake -DNO_FMOD=${_nofmod} \
+ -DGME_INCLUDE_DIR='/usr/include/gme' \
+ -DFMOD_INCLUDE_DIR="${_fmodincdir}" \
+ -DFMOD_LIBRARY="${_fmodlib}" \
+ -DFORCE_INTERNAL_GME=OFF \
+ -DCMAKE_C_FLAGS="$CFLAGS -DSHARE_DIR=\\\"/usr/share/${_name}\\\"" \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -DSHARE_DIR=\\\"/usr/share/${_name}\\\"" \
+ -DCMAKE_EXE_LINKER_FLAGS="$LDFLAGS -Wl,-z,noexecstack" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DINSTALL_PATH=lib/$_name \
+ -DINSTALL_PK3_PATH=share/$_name \
+ .
+ make
+
+ cat >"${_name}.sh" <<EOF
+#!/bin/sh
+exec /usr/lib/${_name}/${_name} "\$@"
+EOF
+
+ cp "${srcdir}/launcher.desktop" "${_name}.desktop"
+
+ mkdir -p 'icons'
+ convert 'src/win32/icon1.ico[2]' 'icons/48.png'
+ convert 'src/win32/icon1.ico[3]' 'icons/32.png'
+ convert 'src/win32/icon1.ico[4]' 'icons/16.png'
+}
+
+package() {
+ cd $_name
+
+ install -D "${_name}.sh" "${pkgdir}/usr/bin/${_name}"
+
+ make install DESTDIR="$pkgdir"
+
+ ln -s /usr/share/$_name/${_name}.pk3 "$pkgdir"/usr/lib/$_name/${_name}.pk3
+ if [[ -n "${_fmodex}" ]]; then
+ install 'liboutput_sdl.so' "${pkgdir}/usr/lib/${_name}/"
+ fi
+
+ mkdir -p "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/doc/$_name/licenses "$pkgdir"/usr/share/licenses/$pkgname
+
+ desktop-file-install --dir="${pkgdir}/usr/share/applications" "${_name}.desktop"
+
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor"
+ (
+ cd 'icons'
+ export XDG_DATA_DIRS="${pkgdir}/usr/share"
+
+ local _file
+ for _file in *.png; do
+ xdg-icon-resource install --noupdate \
+ --novendor \
+ --size "${_file%.png}" \
+ "${_file}" \
+ "${_name}"
+ done
+ )
+}
diff --git a/launcher.desktop b/launcher.desktop
new file mode 100644
index 000000000000..11a74a277144
--- /dev/null
+++ b/launcher.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=QZDoom
+GenericName=Advanced Doom source port with true color renderer
+Icon=qzdoom
+Exec=qzdoom %F
+Terminal=false
+MimeType=application/x-doom-wad;
+Categories=Game;ActionGame;