summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2019-05-28 08:31:34 +0200
committerBjörn Bidar2019-05-28 08:31:34 +0200
commitca5f9cdd63705c58ac0ae66da08120a5acb58c0b (patch)
tree4a85b4ac8e643bd1fba0e36d978dbfa460038510
downloadaur-qzxing-git.tar.gz
add pkg
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca3d958c463f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue May 28 06:30:42 UTC 2019
+pkgbase = qzxing-git
+ pkgdesc = Qt/QML wrapper library for the ZXing library. 1D/2D barcode image processing library
+ pkgver = 05fdc3.r191.g961e24f
+ pkgrel = 1
+ url = https://github.com/ftylitak/qzxing
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = qt5-multimedia
+ depends = qt5-declarative
+ provides = qzxing
+ conflicts = qzxing-git
+ source = qzxing::git+https://github.com/Thaodan/qzxing#branch=wip_qml_plugin
+ md5sums = SKIP
+
+pkgname = qzxing-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3fd264fbd8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Björn Bidar <theodorstormgrade@gmail.com>
+_pkgname=qzxing
+pkgname=$_pkgname-git
+pkgver=05fdc3.r191.g961e24f
+pkgrel=1
+pkgdesc="Qt/QML wrapper library for the ZXing library. 1D/2D barcode image processing library"
+arch=('i686' 'x86_64')
+url="https://github.com/ftylitak/qzxing"
+license=('Apache')
+depends=('qt5-multimedia' 'qt5-declarative')
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($pkgname)
+source=($_pkgname::git+https://github.com/Thaodan/qzxing#branch=wip_qml_plugin)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+build() {
+ mkdir -p "$srcdir"/build
+ cd "$srcdir"/build
+ qmake -makefile ../"$_pkgname"/src/QZXing.pro \
+ PREFIX=/usr \
+ CONFIG="qzxing_multimedia plugin"
+ make PREFIX=/usr
+}
+
+
+package() {
+ cd "$srcdir"/build
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: