summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaekyung Kim2019-07-12 05:45:31 +0900
committerTaekyung Kim2019-07-12 05:45:31 +0900
commit324432272d0cf55eab51da7a26e47bdcc49a95bd (patch)
treecf4da8be7dbb7b865a8378f8038b0fdf7338f1a6
parenta899fa5bc03ca4724548b3afab40e9658d675b67 (diff)
downloadaur-324432272d0cf55eab51da7a26e47bdcc49a95bd.tar.gz
Initial commit
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18bd4e48db4f..f9fe47a42b84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = r-abind
- pkgdesc = Combine Multidimensional Arrays
+ pkgdesc = Combine multidimensional arrays into a single array, a generalization of 'cbind' and 'rbind'.
pkgver = 1.4.5
pkgrel = 1
url = https://cran.r-project.org/package=abind
arch = any
- license = LGPL
- depends = r
+ license = LGPL2
+ license = LGPL2.1
+ license = LGPL3
+ depends = r>=1.5.0
source = https://cran.r-project.org/src/contrib/abind_1.4-5.tar.gz
md5sums = 136f981e1c4f618b64a87faaa7797c97
diff --git a/PKGBUILD b/PKGBUILD
index c6f5c3c21f8c..b1023c3e850d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
+# Maintainer: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
+# Contributor: Alex Branham <branham@utexas.edu>
+
_cranname=abind
_cranver=1.4-5
_pkgtar=${_cranname}_${_cranver}.tar.gz
pkgname=r-abind
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Combine Multidimensional Arrays"
+pkgdesc="Combine multidimensional arrays into a single array, a generalization of 'cbind' and 'rbind'."
arch=('any')
url="https://cran.r-project.org/package=${_cranname}"
-license=('LGPL')
-depends=('r' )
-
-
-
+license=('LGPL2' 'LGPL2.1' 'LGPL3')
+depends=('r>=1.5.0' )
source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
md5sums=('136f981e1c4f618b64a87faaa7797c97')
build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL "${_pkgtar}" -l "$srcdir"
}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership "$_cranname" "$pkgdir"/usr/lib/R/library
}
+